Installation des mjpg-streamer.

  • Hmm, ich habe jetzt gerade nochmal nachlesen müssen welchen Pi Du einsetzt. Das ist definitiv nicht in Ordnung. Hast Du mal versucht den Pi per Lan oder W-Lan zu betreiben? Oder andesrt herum gefragt an was hängt denn Dein Pi?

  • Also eigentlich bin ich ja absoluter Kupferfan und habe auch die Burg
    hier fast komplett verkabelt. Im Eingangsbereich liegt allerdings
    nichts in greifbarer Nähe, weshalb ich mich für den PI 3 mit WLAN
    entschieden habe. Auch in der Testphase hängt er über WLAN an ner 7490.
    Kupfer habe ich im Experiment noch nicht versucht; aber das kann man
    sicherlich auch mal ganz einfach probieren.
    Wie gesagt, gestern gings am PC extrem flott, auch über WLAN!


    LG Christian

  • Eigentlich sollte beim Pi3 ziemlich schnell sein da dieser eine eigen Lane zum SOC hat degegen müssen sich alle USB Ports eine Lane teilen.


    Wie weit ist denn der Pi zum Acces Point entfernt?


    Evtl. mal die Qualität und die Framerate herab setzen.

  • <10 m
    Ja wie gesagt, werd mal mit Kupfer, Framerate und Snapshots spielen.


    Hoffe ein Chemiker kriegt das hin :/



    Mal ganz was anderes: Wie hängst Du Deinen Raspberry ein? Ich bin mit 2. HDMI am Monitor und Logitech USB Transmitter (zum Umstöpseln vom PC) drauf.
    Surfen am Raspberry bringt das Ding immer schnell zum abschmieren (3 offene Seiten reichen meist), daher switche ich immer wieder hin und her, wenns mal wieder länger dauert.
    Eigentlich schade, dass das Ding nicht etwas mehr Power hat. Aber war wohl Absicht so.

  • Hey Christian,
    ich erledige alles über die Putty Konsole. Würde ich dir auch empfehlen zumindest jetzt noch zum ausprobieren.
    Ich habe auch immer 2 Verbindungen offen eine traced die andere zum überwachen + Winscp (FTP) zum bearbeiten der config und zum hoch und runterladen diverser Dateien.

  • Hallo Andreas,


    ich hab mir heute den SSH über XDR eingerichtet. Feine Sache, ohne umstöpseln am PC arbeiten zu können.


    Derweilen macht mir ELCOM auf den Android Tablets etwas Ärger.


    Der Stream funktionert perfekt, aber anrifen kann ich von Tablet aus einfach nicht. Bin zwischenzeitlich draufgekommen, dass unter Eingang/Kamera bei SIP- ID EIngang die Nebenstelle des RASPI stehen muss. Bei Fritz in der Form **XYZ!
    Damit kann ich jede andere Nebenstelle oder auch Festnetznummern anrufen, nur nicht den RP.


    Im Trace taucht folgende Fehlermeldung auf: Sip/2.0 400 Bad Request


    Darf ich Dich nochmal um Deinen Rat bitten?


    Danke & LG,


    Christian

  • Hey,
    also von DoorPi auf die Tablets gehen?


    Code
    1. 2016-06-05 15:55:05,468 [ERROR] [doorpi.sipphone.from_linphone] Missing mandatory header [Max-Forwards] for message [ACK]

    Hier ist anscheinend der Übeltäter die FritzBox. Aber da sollte einer mal darüber schauen der mehr Ahnung von den RFC Normen hat.


    Zitat

    So indeed, there is no "Max-Forwards" header sent with the INVITE requests, but, according to the SIP RFC 3261: "A valid SIP request formulated by a UAC MUST, at a minimum, contain the following header fields: To, From, CSeq, Call-ID, Max-Forwards, and Via; all of these header fields are mandatory in all SIP requests."
    After researching a bit the source code of pjsip, I found that actually almost all messages originating from it don't have Max-Forwards fields.

  • Erledigt!


    Meine Dummheit ?( Natürlich muss dann in die doorpi config Datei die Nebenstelle der ELCOM zu AdminNumbers!
    Also unter ELCOM Eingang/ Kamera SIP-ID Eingang die **XYZ eintragen und bei der doorPI config Datei bei AdminNumbers einen neuen Schlüssel mit ebenfalls **XYZ und Wert = active eintragen.

    Jetzt gehts.


    Was mich allerdings etwas irritiert, ist dass das Mikro am RASPI bei Anruf auf den Raspberry trotz höchster Einstellung sehr, sehr leise ist. In der Gegenrichtung passt dann alles.
    Kann man dazu irgendwas sagen? Einstellungen?


    Viele Grüße,


    Christian

  • Vielen Dank! Bin vorhin dann schon selber draufgekommen. Die Visualisierung in Linux ist für mich immer noch recht gewöhnungsbedürftig. Da übersieht man schon mal was.
    Immerhin hört es sich nun viel besser an mit AG.
    Jetzt muss nur noch der Verstärker für den K50 her, dann passt das hoffentlich soundtechnisch.


    LG Christian