Welche Audio Hardware

  • Ich habe alles soweit am Laufen. Aber mit der Hardware bin ich noch nicht glücklich. Ich setze von Conrad eine USB Soundkarte ein, einen passenden 8 Ohm Lautsprecher mit Kunststoffmembran von Visaton und einen Verstärkerbausatz sowie ein Ansteckmikrofon.
    Aber ich habe entweder eine massive Rückkopplung wenn ich den Poti und/oder den alsamixer hochdrehe oder es ist so leise, dass ich am Lautsprecher nichts mehr höre. Das Mic ist auch nicht die Wucht, geht aber einigermaßen. Man muss schon nah ran. Daher die Frage. Wer hat denn eine laufende Installation des DoorPi und kann eine passendes Hardware Setup empfehlen. Gerne mit den getroffenen Einstellungen. Aktuell kann ich den DoorPi so nicht einbauen :(

  • Hallo Marcuss,
    was Du machen könntest währe das Du so weit wie möglich mit dem Micro vom Lautsprecher weg setzt. Evtl sogar ein Gehäuse um das Micr und Lautsprecher von hinten anbringst. Das ganze ein wenig auskleidest mit Mineralwolle oder ähnlichem, was Du gerade so zur Verfügung hast. Was du noch tun kannst sind von der Soundkarte zum Micro beide Pluskontakte auf ein Kondensatormicro zu legen.


    Du musst versuchen den Schall vom Lautsprecher so gut es geht nur nach vorne strahlen zu lassen, das ist sehr wichtig.
    So genauso bei dem Micro das dieser nur den Schall von vorne bekommt und nicht so doll von der Seite.


    Besorge dir am besten ein Kapselmicro diese kosten nur ein paar cent. Nimm eines mit 10mm oder größer. Diese Ansteckmicro´s sind nicht gerade der bringer.

  • Ist ja witzig, den gleichen Lautsprecher habe ich mir auch ausgesucht. Der Lautsprecher scheint mir sehr geeignet.
    Da ich keine Ahnung hatte, habe ich mir dieses Mikrofon besorgt.
    Dieses habe ich komplett entkernt, also alles Gehäusemäßige weg geschmissen. Übrig bleibt nur eine einfache Elektret-Kapsel an einem 3.5mm Klinke-Stecker :D Hätte man vermutlich auch einfacher haben können.
    Soundkarte benutze ich diese. Glaube die war noch billiger als ich die gekauft habe.


    Mit diesem Setup bin ich bisher zufrieden. Bin aber auch noch in der Testphase.


    Hast du schon mal geschaut, ob Du vielleicht das Problem hast, was ich hier beschrieben habe. Das hatte ich nämlich und hätte die Hardware schon fast aus dem Fenster geschmissen :D

  • Nea: brauchen die Kapselmicros nicht eine aktive Versorgungsspannung? Und meinst du ich muss L+/R+ von der Klinke zusammenlegen, oder wie ist das gemeint? Im Moment ist das Teil noch auf der Arbeitsplatte und nicht eingebaut. Auskleiden mit Mineralwolle geht also noch nicht. Ich verlege das Mic aber mal etwas weiter weg und richte es entgegengesetzt aus. Dann sieht man ja ob es hilft.



    Joker: das teste ich mal und gebe Feedback ob's geholfen hat. Ich bestelle mir dann wohl zur Not mal diese Soundkarte, falls mit den anderen Maßnahmen keine Besserung aufkommt.


    Gibt es denn keine "produktive" Konfiguration bei irgend jemandem, die sich in der Praxis bewährt hat?

  • Hallo Marcuss,
    Ja die beiden plus des linken und rechten Kanals gebrückt an das Micro.
    Jein früher mussten diese verstärkt werden, da hast Du vollkommen Recht, das ist aber schon länger her. Bei den heutigen Soundcards ist eine Elko in Soundkarte verbaut. Das ist daher zu führen da diese Kapsel Micro´s sehr billig in der Herstellung aber doch ausreichend empfindlich sind und sich fast für alle Anwendungen eignen deswegen werden diese fast auschlieslich verwendet.


    Die Einstellung die Joker meinte sind ebenfalls sehr wichtig, nur kann man diese leider nicht eins zu eins, von jemanden andereren, kopieren.

  • Also bei mir funktioniert das nicht bzw. vermutlich bin ich zu dösig dafür. Allgemein sieht die Konfiguration aber ganz vernünftig aus so wie ich das verstehe. Dennoch würde ich gerne den Mic Playback switch ausschalten und das Volume auf 0 stellen.


    Folgendes wird bei mir aufgelistet bei amixer -c1 contents


    Nun habe ich versucht die Mic Playback Volume und den switch abzuschalten mit

    Code
    1. pi@DoorPi:~ $ sudo amixer cset numid=5 0



    Dann kommt:

    Code
    1. amixer: Control default element write error: Operation not permitted


    beim Versuch mit

    Code
    1. pi@DoorPi:~ $ sudo amixer cset numid=4 off


    kommt

    Code
    1. numid=4,iface=PCM,name='IEC958 Playback Default'
    2.  ; type=IEC958,access=rw------,values=1
    3.  : values=[AES0=0x00 AES1=0x00 AES2=0x00 AES3=0x00]



    und anscheinend ist wieder alles da wo es angefangen hat.


    Zitat
    Code
    1. pi@DoorPi:~ $ amixer cset numid=9 20
    2. amixer: Cannot find the given element from control default





    hmmm...Wat nu? :huh:


    EDIT: Habs anders gelöst. In Windows User Manier :-)


  • Danke Joker. Hätte mit Sicherheit funktioniert. Ich hab's zur Abwechslung mal ganz simpel per UI gelöst. Eine Seltenheit :-)


    Andere Frage. Hat jemand schon mal ein Mirofon verbaut, was normalerweise zu Siedle und Co Anlagen als Ersatzteil angeboten wird? Die gibts ja zuhauf auf einschlägigen Auktionsportalen und sie haben meist eine dardwareseitige Entkopplung durch Gummilager. Außerdem sollten Sie wittereungsbeständiger sein, als die üblichen Indoor Mics. Kann man die an den Line in der USB Karte per angelöteter Klinke anschließen?


    Grüße
    Marcus

  • In dem von dir verlinkten Beitrag wird die komplette Sprecheinheit inkl. der Elektronik verwendet. Inkl. Verstärker. Wenn ich mir die Bilder aber genauer anschaue, dann wird hier wohl tatsächlich nur das Mic direkt abgegriffen und auf die Klinke gelegt


    Ich denke im Moment daran sowas hier direkt mit einer Klinke zu verlöten:


    http://www.ebay.de/itm/SIEDLE-…t%3D6%26sd%3D191616860103


    Das gibts auch günstiger wenn man ein wenig sucht.

  • Das geht schon das Micro an den Line In Eingang dann musst Du aber das Signal verstärken sprich einen kleinen Vorverstärker zwischen schalten.


    MarcusS
    Puhh 62€ für ein Micro. ich denke nicht dass das Mikro so viel Mehrwert bietet.


  • Neeee, viel zu viel. Da bin ich bei dir. Aber das gibt's wie gesagt auch günstiger
    Click



    Ich habe gerade noch mal mit den neuen ALSA Settings getestet und muss sagen, dass die Rückkopplung nun weg ist. Die Sprachqualität ist nun wirklich in Ordnung, wenn man das Mic playback abschaltet/muted. Alles Andere erzeugt eine massive Rückkopplung.


    motom001_new. Vielleicht nimmt man den Hinweis mit in die Standard-Installationsdokum mit auf? Denn das verusacht vermutlich bei jedem dieses Phänomen.


    Joker: Danke!


    Nun habe noch das Phänomen, dass ich ein ständiges Knattern und Surren auf dem Lautsprecher habe. Vor allem dann, wenn der MJPG Streamer läuft. Schalte ich ihn ab, ist sofort Ruhe. Ist das ein Fall für Galileo Mystery oder gibt's da eine plausible Erklärung? Ich habe es mal aufgenommen und beigefügt. Muss man etwas lauter anhören.
    Knattern.zip


  • Ich habe gerade noch mal mit den neuen ALSA Settings getestet und muss sagen, dass die Rückkopplung nun weg ist. Die Sprachqualität ist nun wirklich in Ordnung, wenn man das Mic playback abschaltet/muted. Alles Andere erzeugt eine massive Rückkopplung.


    Wie sind Deine Einstellungen denn jetzt? mache mal bitte

    Code
    1. amixer -c1 contents
    2. und/oder
    3. amixer -c0 contents


    Danke


  • Ich habe gerade noch mal mit den neuen ALSA Settings getestet und muss sagen, dass die Rückkopplung nun weg ist. Die Sprachqualität ist nun wirklich in Ordnung, wenn man das Mic playback abschaltet/muted. Alles Andere erzeugt eine massive Rückkopplung.


    Wie sind Deine Einstellungen denn jetzt? mache mal bitte

    Code
    1. amixer -c1 contents
    2. und/oder
    3. amixer -c0 contents


    Danke


  • Ich habe gerade noch mal mit den neuen ALSA Settings getestet und muss sagen, dass die Rückkopplung nun weg ist. Die Sprachqualität ist nun wirklich in Ordnung, wenn man das Mic playback abschaltet/muted. Alles Andere erzeugt eine massive Rückkopplung.


    Wie sind Deine Einstellungen denn jetzt? mache mal bitte

    Code
    1. amixer -c1 contents
    2. und/oder
    3. amixer -c0 contents


    Danke