Pulas doorpi

  • Hallo,


    nach langen Pausen habe ich jetzt endlich meinen doorpi seit gestern produktiv.


    Habe folgendes Setup:
    Raspi 2 per Ethernet angebunden
    Arduino per I2C mit dem Raspi verbunden
    USB-Soundcard am Raspi
    Alte Gegensprech-Anlage ausgeschlachtet und Mikro und Lautsprecher erbeutet
    Code/RFID-Reader per Wiegand am Arduino (dafür die Werte per Hash und Salt verschlüsselt in der ini hinterlegt, from_i2c entsprechend adaptiert)
    2 Klingeltaster (2 Wohnungen) beleuchtet per 12V
    Ein Taster innen für zukünftiges Öffnen des noch nicht montierten doormatic - inkl. zweifarbiger LED zur Anzeige des Schließer-Status. Beides über Arduino angebunden. Ansteuerung des doormatic wird per fhem erfolgen.
    Tuerschild und Hausnummernschild lasern lassen beim Schmied meines Vertrauens, beleuchtet mit LED-Stripe-Resten, angesteuert über Arduino
    Angebunden an fhem - Dank dafür an @pahenning, leider konnte ich das Modul in fhem noch nicht zum Laufen bringen, aber seine Arbeit hat mir viel Kopfzerbrechen erspart, weil ich einiges abkupfern konnte. Csrf-token für fhem in py implementiert)


    Folgende Erfahrungen konnte ich bisher machen:
    Ohne PiFace scheinen die Taster am Raspi zu prellen (was sich in mehr oder weniger regelmäßigem "Fehlklingeln" äußert --> Heute umgebaut, sodaß die Taster am Arduino hängen, wo sie per Bounce2 entprellt werden (habe ich so seit etwa zwei Jahren ohne eine einzige Fehlzündung mit fhem an vier Tastern im Einsatz). Wird per I2C an den Raspi weitergegeben.


    Echo: Habe Mikro und Lautsprecher blöderweise fast nebeneinander verbaut (vorher genaueres Lesen im Forum hätte wahrscheinlich geholfen). Dadurch teilweise starkes Echo an den internen Empfängern (Android-Handies und ein Schnurlos an der FritzBox per DECT).


    Nach versuchter Umstellung auf Raspi3 musste ich feststellen, daß die I2C-Routinen nicht mehr funktionierten (ist auch der Fall bei einem apt dist-upgrade am Raspi2). Hier scheint sich was geändert zu haben. Hatte noch keine Zeit, das nachzuspielen. Werde es mir aber mal ansehen, weil ein Pi3 doch um einiges rascher ist.


    Beim Testen habe ich auf das Handy meiner Frau angerufen (das per Fritz-App angebunden war). Habe hier fast nichts verstanden am Lautsprecher (extrem verzerrtes Audio-Signal) vom doorpi und den Fehler bei der Konfiguration gesucht. War es aber nicht. Habe ihr nun Zoiper installiert, seitdem passt die Qualität (bis auf das Echo natürlich).


    In der ersten Nacht ist doorpi (hatte ihn in einem screen per doorpi_cli --trace gestartet) abgestürzt (Speicherzugriffs-Fehler). Habe mir nun ein kleines Startskript gebastelt, das ihn neu startet wenn er abstürzt. Habe den output in ein Logfile am Server gepiped. Mal sehen.


    Folgendes würde ich anders machen, wenn ich nochmal von vorn beginnen würde bzw. was ich noch ändern werde:


    Habe wild verkabelt - per ATX-Stecker Frontblende und Innenleben entkoppelt, aber das ist trotzdem ziemlicher Wirrwarr. Würde das nächste mal vielleicht eine Platine machen.
    Die Echo-Problematik im Vorfeld genauer anschauen. Da ich sowieso einen Linux-Server im Dauerbetrieb habe, werde ich mir vielleicht mal Asterisk ansehen. Evtl. bringt das Verbesserungen.
    Den Platz genauer ansehen. Habe eine vorhandene Wand-Ausnehmung genutzt. Hier hat die doorpi-Hardware gerade mal so Platz. (Was im Vorfeld vom Einbau ein ziemlich mulmiges Gefühl erzeugt hat)
    Beim Einbau auf das Kabel der Kamera achten. Habe das leider geknickt und muss jetzt auf Ersatz warten, um die Kamera in Betrieb zu nehmen
    Doorpi evtl. vom Server starten und nicht von der SD-Karte. Werde das im Auge behalten. Gibt hier ja Möglichkeiten, den Raspi über Netzwerk zu betreiben.
    Evtl. auch ein Nexion-Display einbinden


    Ansonsten muss ich natürlich erst schauen, wie sich das Ganze im Betrieb bewährt.


    Fotos werden folgen, sobald ich Zeit habe...


    Cheers,


    Pula

  • Hi,


    danke für den Hinweis!
    Momentan hängt das alles ohne Asterisk direkt an der FB 7490 - aber vielleicht installier ich auf meinem Server noch Asterisk und binde den an. Allerdings muss ich sagen, dass die Echo-Problematik eigentlich nicht so schlimm ist. Man redet ja eh nicht eine Stunde mit jemandem an der Haustür ;-)
    Frage: Mit welchem Codec fährst Du denn?


    Cheers,


    Pula