RPI-Cam-Web-Interface

  • @pula001
    Hehe, kommt mir bekannt vor.


    Ich denke wir sollten hierfür einen eigenen Thread auf machen. Ich werde mal einen auf machen und unsere Einträge dort hin verschieben.


    Ich hatte die off topic Beiträge in ein neues Thema verschoben aber wieder zurück verschoben.

  • Hallo Andreas,
    hab das Web-Interface genau wie beschrieben installiert und funktioniert auch. Nur die Bildquallität ist total besch...eiden. Sieht aus wie wenn ein Farbkanal fehlt und rauscht stark. Ist das bei dir auch so?
    Hat jemand eine Idee was da schief läuft? Vielleicht gehört das Thema ja nicht hier her aber ich frags trotzdem mal :-)


    - Raspi 1,2,3 alle mal ausprobiert, immer das selbe
    - Pi-Cam 2, zwei verschiedene Versionen versucht, Kabel getauscht, wieder das selbe Ergebnis
    - verschiedene Netzteile getestet
    - PiFace und DoorPi (habe ich im Moment nicht wieder installiert weil ich die Kamera erst mal richtig zum Laufenbringen will)
    - Jessie, V4l2-Treiber
    - im DoorPi sind die Schnappschüsse auch so schlecht


    Für einen hilfreichen Link oder Hinweis wäre ich dankbar.


    Grüßle
    Wolfgang

  • Hi Wolfgang, versuche nur mal:

    Code
    1. raspistill -o /tmp/test.jpg

    Schaue mal ob das Bild hier ebenfalls schlecht ist.


    Zur Not neues Raspbian flashen, alle Updates machen mit dem Standard Treiber nochmal obigen Befehl eingeben und die Bilder vergleichen.

  • Nein das ist es wahrscheinlich nicht da hier nur ein Fokus-Problem vorliegt. So wie Du den Fehler beschreibst das ein Farbkanal fehlt ist ein anderes Problem. Für mich hört sich das ein bisschen so an als wäre die Stecker unterhalb des Sensors auf der Cam nicht richtig drauf oder aber der Sensor hat einen Macken.

  • Kannst Du mal ein Bild schicken? Da die RaspiCam mit Sicherheit einen 1-Chip Bayer Sensor hat ist es sehr unwahrscheinlich, dass ein loser Kontakt einen Farbkanal verschwinden lässt. Die Farbkanäle kommen ja nicht (wie bei analog) einzeln da raus ein 3-Chip CMOS Sensor ist da garantiert nicht drin :)


    Der Bayer Sensor hat über jedem Pixel einen Farbfilter und die Farbwerte werden aus benachbarten Pixeln zusammengerechnet (2x grün, 1x rot, 1x blau). Der Sensor überträgt nur Helligkeitswerte, vergleichbar mit einem graustufen TIF. Das sind die RAW Informationen. Die Elektronik oder Software dahinter muss die Charakteristik des Sensors kennen und aus den reinen Helligkeitswerten Farben errechnen. Es treten also zu keinem Zeitpunkt die Farbkanäle einzeln auf.


    Was ich mir vorstellen kann wäre ein nicht vorhandener IR Filter und Tageslicht. Das kann im Extremfall auch so aussehen, wie ein fehlender Kanal :) Das hier ist schon ein krasses Beispiel: http://www.networkwebcams.com/…_camera_image-300x211.jpg

  • So sieht's aktuell mit der PiCam NoIR bei mir aus:



    Vielleicht einfach mal etwas mit dem Weißabgleich im RPI-Cam-Web-Interface herumspielen.



    Mit der Einstellung "Auto" hatte ich oft eine starke Verfärbung in Richtung Rosa. Mit "Incandescent" sieht's deutlich natürlicher aus.


    Gruß,


    Thorsten

  • Ja, es ist tatsächlich eine (bzw. 2) NoIR-Kamera der 2. Generation mit 8 MP, die das dann wohl nicht anders kann. Ist halt passiert weil ich mich vorher nicht richtig informiert habe. Allerdings hat eine der Kameras wohl schon ein Problem mit dem Fokus oder der Linse. Die geht wieder zurück und hole mir noch eine "normale".
    Danke für die Hilfe


    Gruß
    Wolfgang


    Nachdem ich mich mit meiner NoIR-Kamera hier so schön blamiert habe, hat's dann mit einer "normalen" wunderbar funktioniert.
    RPI-Cam-Webinterface probiert, - geht
    MJPEG-Streamer - geht (natürlich nicht paralell),
    Kann die Bilder in meinem C4 anzeigen lassen.
    Was dann jeweils nicht mehr geht ist dann die DoorPi-Funktion "take-snapshot", es werden dann keine Bilder in das !BASEPATH!/../DoorPiWeb/snapshots/ eingetragen und die Histoy bleibt dann leer. Leuchtet mir soweit auch ein, da die Kamera dann jeweils belegt ist.


    Ohne RPI-Cam-Webinterface/MJPEG-Streamer:
    Im Dashboard/Configuration gibt es nach "take-snapshot" den Eintrag in "last_snapshot" z.B. "/usr/local/etc/DoorPi/../DoorPiWeb/snapshots/2016-06-07_19-15-24.jpg". Mir würde es reichen wenn ich dieses letzte jpg an meinem C4 angezeigt bekomme, ohne MJPEG-Streamer oder RPI-Cam-Webinterface. Habe keine Ahnung wie ich darauf mit der FB7390 zugreifen kann und/oder ob das überhaupt geht. Idee?



    Gruß
    Wolfgang

  • Hallöchen,
    ich habe gestern nach der Anleitung von "dtp" & "Nea" das Web-Interface installiert und es funktioniert. :-)


    Dankeschön für die Anleitung!!!


    Nun heist es ja, das man die Schreibzugriffe auf die SD Karte minimieren soll, darum möchte ich das Verzeichnis (welches ich noch nicht gefunden habe) auf dem die Video's und Bilder von der RPICam gespeichert werden, auf ein USB LW auslagern.
    Habt ihr vielleicht ein Vorschlag wie ich das umsetzen kann?


    Es geht mir jetzt hauptsächlich darum, wie ich dem Web-Interface sage, das die Bilder und Viedeo's in ein Verzeichnis auf dem USB-Laufwerk gespeichert werden.


    Das USB Laufwerk würde ich nach dieser Anleitung einrichten
    Gruß mario


    Raspi 2 - Jessie - DoorPi -

  • Hallo,
    vorab erst einmal vielen Dank an alle die an diesem Projekt arbeiten. Tolle Sache.


    Ich hab gemäß den diversen Anleitungen DoorPi installiert. Hat soweit erst einmal funktioniert.
    Ich konnte auch über die IP Adresse des DoorPi auf die Weboberfläche von DoorPi zugreifen.


    Nun habe ich noch das RPI-Cam-Web-Interface installiert. Dies funktioniert auch soweit, jedoch kann ich nun die Weboberfläche von DoorPi nicht mehr aufrufen.
    Ich bekomme immer die Meldung "Fehler: Verbindung fehlgeschlagen" im Browser angezeigt, auch wenn ich die IP des DoorPi inkl. Port 80 eingebe. Kann man den Zugriff auf die Weboberfläche des DoorPi wieder manuell einrichten?

  • Den Port hatte ich schon auf 8081 in der doorpi,ini geändert, ohne Erfolg.
    Kann es sein, dass das Problem durch die Installation des apache entstanden ist?


    Code
    1. [DoorPiWeb]
    2. indexfile = index.html
    3. ip = 192.168.2.86
    4. loginfile = login.html
    5. online_fallback = http://motom001.github.io/DoorPiWeb
    6. port = 8081
    7. public = AREA_public
    8. www = !BASEPATH!/../DoorPiWeb
  • Die Fritzbox unterstützt kein Live-Video...


    Das maximale ist zur Zeit ein Live-Bild das sich jede Sekunde aktualisiert.

    Nur mal eine aktuelle Info:


    FB mit Fon C5 und OS 6.80 unterstützt bei mir auf der einen Live-Video-Stream parallel auf dem Fon C5 und der Loxone-App mit einem wirklich flüssigen Video.
    Zumindest solange, bis man das Gespräch bzw. das "Event" an einem Client annimmt. Danach bleibt das letzte Bild auf dem C5 Display als Standbild zu sehen. ;)


    Ich habe übrigens den mjpg-streamer installiert und der macht, wenn er richtig installiert wurde, genau das was er soll ohne den RasPi zu sehr in der CPU-Performance zu belasten.


    Übrigens auch mal von mir an dieser Stelle ein Danke an all die "Bastler", "Moderatoren" und "Tipps-Geber" in diesem Forum. Davon lebt es bzw. "DoorPi" schließlich. :thumbsup: