Beiträge von angel

    Hi also ich hab es jetzt mal mit der neuerung auf verschiedenen Pins ausprobiert aber nicht im log zu sehen. Ich habe auch mal versucht die Pins "von Hand" auf GND zu ziehen auch nichts. Mir scheint als könnte der nicht auf die GPIO's zugreifen. Kann da noch irgendetwas sein?

    Sobald ich den Leser an die Pins mit dem C-Script hänge sehe ich die IDs.

    Ich hab jetzt mal alles aus der DoorPi.ini rausgeworfen was man nicht braucht hat aber nichts gebracht

    Hi ja nach dem starten habe ich einen chip ein paar mal an den leser gehalten. Der hat den Chip erkannt und nachdem nichts kam hab ich den DoorPi wieder beendet damit ich ein sauberes log abziehen kann.

    Fehler ist jetzt weg DoorPi startet auch ganz brav. Aber ich sehe nix im log das es etwas gelesen hätte.

    Vielleicht siehst ja wer mehr.

    Der Wiegand 26 Leser funktioniert ohne probleme wenn ich ihn uber mein C Script abfrage da ich da die gleichen GPIOs verwende sollte der anschluss auch passen.

    doorpi.txt

    Ich habe das jetzt nochmal versucht hier die Ausgaben

    für

    [meinleser_InputPins]

    123456 = call:0151123456789

    kommt die Meldung

    Exception NameError: Channel must be an integer or list/tuple of integers




    für

    [meinleser_InputPins]

    test = call:0151123456789

    bekomme ich die Meldung

    Exception NameError: invalid literal for int() with base 10: 'test'


    :rolleyes::rolleyes::rolleyes:

    Problem gefunden........

    Zunächst mal mein Netzwerkaufbau. Ich habe eine FritzBox an der als ExposedHost meine Unifi USG sitzt. Die funktioniert als Firewall, Failover zu LTE, Netztwerkmanager und stellt drei Netzte bereit. Ein Gastnetztwerk, ein "Normals Netzwerk" für Internet facing devices und ein Haustechnik Netz.

    Im Haustechniknetzwerk gibt es keine Internetfreigabe und alles was da rein oder Raustelefonieren will ist in der Firewall freigeschalten. Der DooPi hing jetzt in besagtem Haustechnik Netzt, war mit allen Ports freigeschalten hatte zwar Verbindung zur Fritztbox und konnte Anrufe tätigen aber die Sprachpakete kamen nicht durch.

    Ich hab jetzt mal ein viertes VLAN dazu gepackt und den DooPi direkt an die Fritzbox gehängt siehe da es funktioniert.

    Jetzt mal schauen ob ich noch einen NAT hinbekomme.


    Danke an alle die sich die Mühe gemacht haben mir zu helfen.

    Hi funktioniert auf anhieb leider nicht.


    ich habe das ganze da einebaut

    root@turkinkel:/usr/local/lib/python2.7/dist-packages/DoorPi-2.5.1-py2.7.egg/doorpi/keyboard# ls -l

    -rw-r--r-- 1 root staff 4091 Mär 22 01:43 AbstractBaseClass.py

    .....

    -rw-r--r-- 1 root staff 7642 Mär 30 18:59 from_wiegand.py

    -rw-r--r-- 1 root staff 81 Mär 22 01:43 __init__.py

    -rw-r--r-- 1 root staff 249 Mär 22 01:43 __init__.pyc

    -rw-r--r-- 1 root staff 5965 Mär 22 01:43 KeyboardInterface.py

    -rw-r--r-- 1 root staff 6982 Mär 22 01:43 KeyboardInterface.pyc


    Mit der doorpi.ini

    Dateien

    • doorpi.txt

      (63,62 kB, 2 Mal heruntergeladen, zuletzt: )

    in der alsa.conf habe ich folgendes drinne

    defaults.ctl.card 2

    defaults.pcm.card 0

    die asound.conf bit es wohl unter Buster nicht mehr die nennt sich jetzt wohl .asoundrc

    pcm.!default {

    type asym

    capture.pcm "mic"

    playback.pcm "speaker"

    }

    pcm.mic {

    type plug

    slave {

    pcm "hw:2,0"

    }

    }

    pcm.speaker {

    type plug

    slave {

    pcm "hw:0,0"

    }

    }


    pcm.input {

    type hw

    card 2

    }


    pcm.output {

    type hw

    card 0

    }


    ctl.!default {

    type hw

    card 0

    }


    Mir ist gerade noch aufgefallen das "open '/dev/snd/pcmC0D0c' " nicht funktionieren kann da das device nicht existiert sondern /dev/snd/pcmC0D0p existiert. Ich bin mir jetzt nicht sicher ob oder wo linphone das jetzt her hat das es hier ein capute device haben will aber das gibt es schonmal nicht da unter C0D0 nunmal der lautsprecher hängt. Das gleiche gilt für das Micro hier versucht linphone ein playback device zu öffnen das es nicht gibt.

    Zumal der ja auch die Aufnahme des Micros am DoorPi auch im record file landen.


    Besteht die möglichkeit das DooPi bzw. linphone nicht mit zwei unterschiedlichen devices für aufnahme und wiedergabe klarmommt?

    Hi danke für die Antwort. Habe nicht an die nummer im Log gedacht ist jetzt mal raus.

    Ok so wie das jetzt gelesen habe ligt das daran das die Audiokanäle nicht geöffnet werden können da sie bereits in Verwendung sind.

    Jetzt kenne ich wenigstens mal mein Problem und weiß worann es hakt. Aber wie lösen? ich hab es mal mit

    sudo aoss doorpi_cli --trace

    versucht wie in dem Link beschrieben aber ich bekomme immer noch die Ausgabe

    2020-03-30 15:43:20,208 [INFO] [doorpi.sipphone.from_linphone] Registering all soundcard handlers

    2020-03-30 15:43:20,268 [INFO] [doorpi.sipphone.from_linphone] Card 'ALSA: default device' added

    2020-03-30 15:43:20,279 [INFO] [doorpi.sipphone.from_linphone] also error in pcm_hw.c:1711 - open '/dev/snd/pcmC0D0c' failed (-2)

    2020-03-30 15:43:20,279 [INFO] [doorpi.sipphone.from_linphone] also error in pcm_dsnoop.c:638 - unable to open slave

    2020-03-30 15:43:20,285 [INFO] [doorpi.sipphone.from_linphone] Card 'ALSA: USB2.0 Device' added

    2020-03-30 15:43:20,286 [INFO] [doorpi.sipphone.from_linphone] also error in pcm_hw.c:1711 - open '/dev/snd/pcmC1D0c' failed (-2)

    2020-03-30 15:43:20,288 [INFO] [doorpi.sipphone.from_linphone] Card 'ALSA: bcm2835 ALSA' added

    2020-03-30 15:43:20,298 [INFO] [doorpi.sipphone.from_linphone] also error in pcm_hw.c:1711 - open '/dev/snd/pcmC2D0p' failed (-2)

    2020-03-30 15:43:20,298 [INFO] [doorpi.sipphone.from_linphone] also error in pcm_dmix.c:1108 - unable to open slave

    2020-03-30 15:43:20,300 [INFO] [doorpi.sipphone.from_linphone] Card 'ALSA: AK5371' added

    Eigentlich sollte pcmC0D0c der Lautsprecher und pcmC2D0p Das Micro sein


    Es macht auch keine unterschied ob alsa-oss installiert ist oder nicht.

    Hi,

    der Alsamixer erkennt beide Geräte und die Lautstärke steht jeweils bei 100%.

    Ja ich habe zwei verschiedene Geräte einmal einen USB Lautsprecher

    USB Lautsprecher


    und ein separates USB Mikrophone

    USB Micro


    Weil billig und beim Lautsprecher hab ich einen eingebauten Verstärker und brauche keine Separate Stromversorgung.


    Ich habe jetzt mal den DoorPi im Trace gestartet und einen Anruf getätigt anbei da Logfile dazu. Vielleicht findest jemand was.


    doorpi.txt


    Oder könnte es gar sein das DoorPi nicht mit zwei Devices umgehen kann.

    Hi,

    nein den Wahltone höre leider auch nicht nur das piepen wenn er auflegt hört man. Wenn ich z.B. Die aufzeichnug des Anrufes mit aplay abspiele hört man auf dem DoorPi alles was über das Micro vom DoorPi eingesprochen wurde und was von der Gegenstelle gesprochen wurde. Alsamixer habe ich hoffentlich richtig eingestellt zumindest zeigt er das richtige device an. Ich bin mir nur nicht 100% sicher da ich ein USB Micro und einen seperaten USB Lautsprecher benutze. Log von einem Anruf zeichne ich nacher mal auf und lad es hoch.

    Danke schonmal!

    Hallo zusammen,



    ich habe mit meinem DoorPi ein Problem und vielleicht kann mir jemand weiterhelfen. Sonst beiß ich da bald rein.

    Und zwar folgendes wenn ich mit einem beliebigen (unter AdminNumbers) eingetragen gerät den DoorPi anrufe oder vom DoorPi einen Anruf starte kommt an keiner der Seiten auch nur ein mucks raus. Komischerweise sind die aufnahmen der Gespräche vollständig. Das heißt wenn ich nach der Beendigung des Telefonats die .wav Datei anhöre ist da das ganze Gespräch mit to von beiden Micros drinnen.

    Wenn ich den Klingelknopf betätige höre ich auch keinen Wählton sobald ich an der Gegenstelle rangehe ist alles ruhig und wenn die maximale Gesprächzeit abgelaufen ist hupt der DoorPi ziemlich lauf und legt auf :cursing: Ich hab mittlerweile die verschiedensten Konfigurationen und was capture und playback device angeht durch...

    Ist bestimmt nur irgendwo eine Kleinigkeit aber ich komme nicht drauf.




    Wenn ich in das Start log schaue sind er da alle Audio ein und Ausgabegeräte und wenn ich eine Testaufnahme mache und wiedergebe funktioniert auch alles so wie es soll.

    Gibt es da noch irgendeinen Trick oder Mute Knopf den man machen kann?



    Vielen Dank schonmal

    Hallo,


    sorry das ich den Beitrag versucht habe zu kapern. Wollte eigentlich gerade einen aufmachen zu meinem Problem da hab ich den gefunden und fälschlicher weise mein Problem als Kommentar reingepackt. Mein Audioproblem habe ich mittlerweile eingegrenzt "lag" an den Lautsprecher und Mikrophone Einstellungen da habe ich was so verbogen das je nachdem wer versucht hat Audio wiederzugeben es am Lautsprecher ankam oder nicht. Egal hab den Pi jetzt nochmal mit einem frischen Buster Image neu aufgesetzt. An der stelle wollte ich den DoorPi eigentlich nur als Softephone missbrauchen und als zusätzliche Sprechstelle einrichten. Eigentlich würde mir da ja irgendein Softephone langen aber bei Dr. Google hab ich nichts wirklich passendes gefunden. Kennt jemand hier eine Alternative?


    Danke und nochmals Entschuldigung für den falschen Beitrag.

    Hi,

    ich baster gerade genau sowas. An dem Raspi hängt ein 10.1" Touch ein USB Micro und ein Aktiver USB Lautsprecher.

    Auf dem Display wird meine Hasu Visualisierung angezeigt und DoorPi möchte ich gerne zum Annehmen der Anrufe des DoorPi an der Haustüre nehmen. Anrufe kann ich zwar annehmen aller dings kommt weder Ton an noch geht Sprache raus. Man hört 30s lang nix dann kommt ein piep piep und der DoorPi legt auf. Muss oder kann man dem DoorPi irgendwo sagen das er bei eingehenden anrufen nicht nur aufzeichen soll sonder das ganze an ein audiogerät ausgeben?


    Danke und Grüße