Suchergebnisse

Suchergebnisse 1-20 von insgesamt 55.

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • DoorPi - mit Gira-Modulen

    maxkr - - komplettes Projekt

    Beitrag

    Hi steph, also ich muss zwar mit dem RFID-Chip (Schlüsselanhänger bei mir) das Display nahezu berühren aber die Erkennung klappt dann zuverlässig.

  • Hi Arno, ja das geht grundsätzlich schon. Was für einen RasPi hast du denn im Einsatz? Mit dem 3er überhaupt kein Problem, mit den älterne Single Core RasPi ist anstelle vom Apache evt. lighttpd die bessere Wahl, weil der weniger Ressourcen braucht. Außerdem muss der Port über den du dann auf diesen Webserver zugreifen willst natürlich ein anderer sein als der vom DoorPi... Viele Grüße, Max

  • Sorry vertippt! Danke Wal! Und kommst du jetzt weiter Arno?

  • Hi Arno, ja die Rechte sollten nicht das Problem sein. Ich denke du musst dir das mit dem modprobe-Verzeichnis mal anschauen und ob die Kamera auch aktiviert ist. Außerdem findest du vielleicht Hinweise mit: dmeg | grep video Bei mit sieht das dann z.B. so aus: Quellcode (3 Zeilen)

  • Hi Arno, vielleicht ein Rechtethema. Was liefert dir denn: ls -la /etc/init.d/mjpg_streamer sollte etwa so aussehen: -rwxr-xr-x 1 root root 1039 Apr 12 10:05 /etc/init.d/mjpg_streamer Im Verzeichnis /etc/modprobe.d/ sind diverse *.conf-Dateien ist da der Treiber ggf. mit blacklist aufgeführt? Dann würde er den nämlich nicht laden... Da es schon funktioniert hat unwahrscheinlich, aber: Hast du die Kamera per raspi-config > Interfacing Options aktiviert? Viele Grüße, Max

  • Hallo Arno, hast du schon versucht es per: apt-get install imagemagick zu installieren? Kann mich nicht daran erinnern damit Probleme gehabt zu haben...

  • Super, das freut mich Arno!

  • Hallo Arno, habe gerade deinen Beitrag auf Github gesehen. Kannst du mir mal sagen welche Firmware-Version der Fritz-Box du hast. Ich habe wie gesagt seit der 6.87 das Problem gehabt, dass im der Anmeldename (bei dir 622) und auch das Kennwort zu einfach war. gesehen hat man das nur, wenn man bei den Telefoniegeräten in der Übersicht die Gräte anschaut. Mein Eintrag mit dem DoorPi war dann rechts (d.h. links von den Buttons) mit einem kleinen Warnsymbol mit Ausrufezeichen versehen. Erst nach Änd…

  • Audio Datei abspielen

    maxkr - - Konfiguration

    Beitrag

    Danke für die Erklärung Martin, jetzt verstehe ich das Problem und eigentlich hast du es auch genauso beschrieben... Per Event wird ein Telefon vom DoorPi angerufen und sobald die Verbindung steht soll eine Datei abgespielt werden anstatt die Sprechverbindung aufzubauen. Was du also bräuchtest, müsste also den Weg nehmen, der üblicherweise über den Mikrofoneingang von der Türsprechstelle beim Angerufenen ankommt. Da fällt mir jetzt aber leider keine Lösung ein, was aber nicht heißt, dass es sie …

  • Vielleicht ist das Absturzproblem gelöst: Durch Zufall habe ich diesen Fork vom mjpg_streamer entdeckt: github.com/jacksonliam/mjpg-streamer Zuerst bin ich auf diese Seite aufmerksam geworden: discourse.octoprint.org/t/avai…onfiguration-options/1106 Die /etc/init.d/mjpg_streamer habe ich dazu wie folgt modifiziert: Quellcode (1 Zeile) Das Beste: die Patches von Nea wollten nicht, scheinen hier aber enthalten zu sein (habe jetzt keinen richtigen Code-Review gemacht...). Mit -ex auto stellt man au…

  • Audio Datei abspielen

    maxkr - - Konfiguration

    Beitrag

    Hi Martin, in der Anahme, dass du dann einen Lautsprecher (mit Verstärker) am Soundausgang vom RasPi betreibst und den Ton dort ausgeben willst: Du könntest ja in der doorpi.ini die Einstellung dialtone entsprechend setzen, dann sollte das sogar schon vor dem Rufaufbau funktionieren. Ansonsten mache ich das auch: Wenn ich eine RFID erkenne, spiele ich einen Ton ab. Ich denke du musst ein wenig mit dem Ausgabedevice herumexperementieren, dann sollte das schon funktionieren. Oder deine Einstellung…

  • Jetzt habe ich mal ein paar Einstellungen durchprobiert aber das "Einfrieren" des Bildes passiert schon recht häufig - auf ein Mal... Einstellungen mit uvcdynctrl bringt bei mir leider gar nichts. D.h. mit mit 'Auto Exposure' kann man den mjp_streamer zuverlässig zum Absturz bringen biggrin.png - danach muss ich ihn neu starten... Das Bild wirkt abends oft auch zu dunkel und tagsüber ist es meistens zu hell. Hier hilft bisher nur ein Neustart vom mjp_streamer. Auch wenn das schon länger her ist,…

  • Um Störeinflüsse weitgehend auszuschließen würde ich dir auch zur digitalen Übertragung der Audio-Daten raten und dir daher empfehlen USB bis zur Außenstelle zu führen. Bei mehr als 5m würde ich dir aber eher so etwas empfehlen: logilink.eu/Produkte_LogiLink/…0m_mit_4_Port_Hub-PoE.htm Allerdings muss deine Verkabelung auch min. CAT5 hergeben... Aber dann hast du immerhin 4 USB-Ports und könntest sogar später evt. eine Webcam nachrüsten und hast auch gleich reserven für einen Audio-Verstärker (um…

  • Ich habe ja die RasPi-Cam am CSI-Port dran. Sollte das mit der Belichtungsnachführung dort auch funktionieren? Ich bekomme da nur eine Fehlemeldung, dass es den Befehl nicht gibt. Bei uvcdynctrl -c wird "Auto Exposure" aber mit aufgeführt... [Nachtrag]: uvcdynctrl -s 'Auto Exposure' 0 bzw. uvcdynctrl -s 'Auto Exposure' 1 könnte funktionieren?! ...mit uvcdynctrl -c -v weiß ich nun mehr: 0=Auto, 1 Manual Mode...! Das mit compare ist auch nicht schlecht was die weißen Tagbilder angeht: >37% Abweich…

  • Danke CBMOD, wenn ich mir dein Beispielskript mit dem Watchdog für den mjpg-streamer anschaue, bekommst du am Port 9000 keine Daten mehr oder? Bei mir kommen immer noch Daten, so dass er den Ausfall bei mir wahrscheinlich gar nicht erkennt auf diesem Weg... Auch jpegs, die ich per Cron hole sind immer valide Bilder... Meine Idee wäre daher, dass ich diese über- oder unterbelichteten Bilder irgendwo ablege und mit den Bildern die ich regelmäßig ziehe irgenwie vergleiche. Stimmen die zu sehr über …

  • Wisst ihr eine Möglihckeit den mjpg_streamer zu überwachen bzw. die Ursache für die Abstürze zu finden: Hatte meinen DoorPi mehrere Wochen im Testbetrieb und dort hat sich der in der Zeit einmal verabschiedet. War mir aber nicht ganz sicher, ob da nicht jemand an die Verkabelung zur Kamera gekommen ist. Hier hat auch nur ein Neustart vom RasPi geholfen. Nach dem Einbau hatte ich meist nach weniger als 12 Stunden einen Ausfall, konnten mit service mjpg_streamer restart aber wieder ein Kamerabild …

  • Welche Fritzbox-Version hast du denn? Bei mir war es wie gesagt so, dass er bei sipserver_username die 620 nicht mehr akzeptiert hat mit der 6.87. Hatte zuvor die Version 6.66 drauf... Habe nun sowohl in der FB als auch im DoorPi einen Namen eingetragen bei dem die FB nicht mehr meckert. Möglicherweise läuft auch auf deinem DoorPi noch was von LinPhone & Co im Hintergrund, also unabhängig vom DoorPi, was zumindest diese Info aus deinem Trace vermuten lässt: Quellcode (6 Zeilen)...Address already…

  • Hi Arno, wenn du in der FritzBox schaust ist dort ein Hinweis bei deinem DooPi unter Telefonie -> Telefoniegeräte zu sehen. Meine FB hat vorgestern ein Update durchgeführt (auf 6.87) und der war der Benutzername bzw. das Kennwort nicht sicher genug... Ich habe nach wie vor nämlich den Eindruck, dass sich dein DoorPi nicht an der FB anmeldet. Oder zumindest nicht richtig. In deiner Konfig ist dein Telefon als AdminNumber eingetragen. Kannst du mit **620 von deinem Telefon auf den DoorPi erreichen…

  • Das mit deiner Kamera ist echt bedenktlich. Einen anderen RasPi hast du wahrscheinlich nicht zum Testen oder?! Ansonsten noch mal Kabel zur Kamera testen: Richtig herum drin, gerade drin, vielleicht auch noch mal beide Enden aufmachen. Und nur um sicherzugehen: Dein RasPi sollte dabei unbedingt vom Strom getrennt sein, ein Kurzschluss beschädigt schnell dauerhaft etwas... Also auch bei mir ist Jessie drauf für den DoorPi, dachte es wäre schon Stretch, das ist aber ein andere Projekt von mir... I…

  • Hallo Arno, nur nicht aufgeben! Ich bin mir sicher, dass du den Vorschlaghammer nicht brauchen wirst! Wenn deine (neue) Fritzbox dann DHCP-, Nameserver und Telefonanlage ist, sollte sie unter einer einzigen IP-Adresse erreichbar sein (Achtung wegen LAN-Port 4...) und die Namensauflösung (ping fritz.box) funktionieren. Ich drücke dir fest die Daumen!!! Max