Nach Testphase Projekt endlich umgesetzt - DoorPi steigt nach einiger Zeit aus

  • Hilfe / Ratschläge

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Da in jedem Forum ein paar Regeln eingehalten werden müssen, möchte ich diese auch vorher hier festlegen und niederschreiben. Die grundsätzliche Netiquette setze ich bei Jedem voraus. Darüber hinaus möchte ich nur spezielle Regeln ansprechen:
- Unterlasse FullQuote sondern nutze Alternativen wie Inline-Quoting
-> siehe auch https://de.wikipedia.org/wiki/Fullquote vs. https://de.wikipedia.org/wiki/TOFU#Alternativen_zu_TOFU
- Unterlasse nichtssagende Antworten wie "Danke" oder "werde ich mal testen" oder ähnliches, sofern Du nicht der Threadersteller bist und einen Lösungsvorschlag angeboten bekommen hast.
- Vermeide Doppel-Posts (zwei Beiträge von Dir hintereinander) sondern editiere wenn möglich Deine Posts.

Danke...

  • Gerade nochmal ähnliche Zeilen im Trace modus wie letzte Nacht erhalten, ich habe das Gefühl, irgendwas schickt meinen Raspberry in eine Art Hibernation mode oder es ist wirklich verursacht durch die Stromversorgung. Das HMI ist sauber, habe da folgende instructions benutzt:

    ussp 60
    thsp 60
    thup 1
    dims 100


    Zur info:
    Der Bewgungsmelder ist auf t min engestellt, ungefährt 2s trigger (RPI HC-SR501). Dieser hängt an einem Relaisboard der dann Input (prodsystem.2) auf GND schaltet. Ist das Event selber vielleicht ungünstig gewählt? Habe auch schonmal gehört das zu häufiges retriggern eines Signales zu Problemen führen kann. Wie habt ihr das realisiert bei euren Projekten?

    1. [EVENT_OnKeyDown_prodsystem.2]
    2. 10 = out:sleep=0,1
    Bilder
    • 21112018 trace.jpeg

      201,7 kB, 1.280×383, 50 mal angesehen

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von Schneis ()

  • Hallo Stefan,

    schöne Anlage!

    Schneis schrieb:

    An der Sekundärseite des Netzteiles messe ich 6V (von mir so eingestellt), an der Haustüre selber 5.1V (Nennspannung für RPI),
    Ist das im Leerlauf? Dann ist der Spannungsabfall auf der Leitung schon heftig. Die Ströme, welche hier fließen, wären sonst interessant.

    Ich würde versuchen den Leitungsquerschnitt zu erhöhen und die Spannung entsprechend anpassen.
    (Noch mehr Leitungen für die Spannungsversorgung zusammen zu schalten)

    ODER
    Z.B. 12 Volt in den Kasten bringen und einen Spannungsregler, für den Raspi, in den Kasten verbauen.

    Viele Grüße
    Olaf
    --
    Wer nicht gekennzeichnete Rechtschreibfehler findet darf sie gerne behalten.
  • Die Idee einen Spannunsregler zu nutzen hatte ich auch schon, würde generell die Ströme senken. Also würdest du auch auf ein Hardware Problem tippen.

    Was mir auch sehr seltsam erscheint ist, wenn der Raspi sich abschießt, reagiert der Nextion nichtmehr. Dieser sollte jedoch unabhängig funktionieren da eigener Chip usw. Falls der Raspi also die Komponenten wie Ethernet und USB ausschaltet würde das ein solchen Verhalten erklären. Werde heute Abend nochmal checken, wenn das Problem auftritt ob alle Interfaces tatsächlich deaktiviert wurden.

    Danach werde ich dann mein Labornetzteil anschließen.
  • Habe die Stromversorgung jetzt über die Schraubklemmen am Piface seperat angeschlossen (versorgt auch den Raspberry mit Strom ) und auch den Nextion versorge ich extern mit Strom. Gerade eben leider wieder von meinem IO Broker eine Nachricht erhalten, dass er den DoorPi nicht anpingen kann.

    Meine Vermutung wäre jetzt noch der Bewegungsmelder der den RPI vielleicht mit Events zu müllt.
    Hatte jemand schon ähnliche Probleme?