Pi Camera geht nicht mehr

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    Da in jedem Forum ein paar Regeln eingehalten werden müssen, möchte ich diese auch vorher hier festlegen und niederschreiben. Die grundsätzliche Netiquette setze ich bei Jedem voraus. Darüber hinaus möchte ich nur spezielle Regeln ansprechen:
    - Unterlasse FullQuote sondern nutze Alternativen wie Inline-Quoting
    -> siehe auch https://de.wikipedia.org/wiki/Fullquote vs. https://de.wikipedia.org/wiki/TOFU#Alternativen_zu_TOFU
    - Unterlasse nichtssagende Antworten wie "Danke" oder "werde ich mal testen" oder ähnliches, sofern Du nicht der Threadersteller bist und einen Lösungsvorschlag angeboten bekommen hast.
    - Vermeide Doppel-Posts (zwei Beiträge von Dir hintereinander) sondern editiere wenn möglich Deine Posts.

    Danke...

    • Pi Camera geht nicht mehr

      Das ist zum aus der Haut fahren!!!!!!!!!!!!!!!!!
      Camera hat funktioniert.

      vcgencmd get_camera
      supported=1 detected=1


      raspistill -o image.jpg
      mmal: mmal_vc_component_enable: failed to enable component: ENOSPC
      mmal: camera component couldn't be enabled
      mmal: main: Failed to create camera component
      mmal: Failed to run camera app. Please check for firmware updates

      In der raspi-config deinstalliert und wieder installiert.
      Aber wieder der gleiche Fehler.
      Was mache ich falsch? mjpeg-streamer ist installiert nach Anleitung.
    • Anscheinend gibt es einen Konflikt zwischen raspistill und mjpg-streamer. Wenn ich diesen mit pkill -9 mjpg-streamer deaktiviere, dann geht plötzlich die Kamera.
      Ich nutzte Raspbian Stretch. Vielleicht liegt es daran, dass mjpg-streamer nicht richtig geht.
      Hat jemand eine Installationsanleitung für Stretch?
    • Neu

      Hallo violancer,
      hast du deinen mjpg streamer nach der Anleitung im Forum installiert? Hast du Raspbian stretch auf deinem Pi?
      Wenn ja, dann must du mjpg streamer im Installationsverzeichnis mit sudo make clean all deistallieren. Du must dann
      ins Verzeichnis mjpg streamer experimental verzeichnis wechseln und die Installation nochmals ausführen.
      Gib dann sudo modprobe bcm2835-4vl2 ein. Anschließend
      /usr/local/bin/mjpg_streamer -i "input_uvc.so -r 640x480 -d /dev/video0 -f 30 -q 80" -o "output_http.so -p 9000 -w /usr/local/share/mjpg-streamer/www"

      Dann müßte es funktionieren.
      Entschuldige die etwas lapse Erklärung.