MJPG-Streamer geht nicht im MJPG Format

  • Bug / Problem

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

Da in jedem Forum ein paar Regeln eingehalten werden müssen, möchte ich diese auch vorher hier festlegen und niederschreiben. Die grundsätzliche Netiquette setze ich bei Jedem voraus. Darüber hinaus möchte ich nur spezielle Regeln ansprechen:
- Unterlasse FullQuote sondern nutze Alternativen wie Inline-Quoting
-> siehe auch https://de.wikipedia.org/wiki/Fullquote vs. https://de.wikipedia.org/wiki/TOFU#Alternativen_zu_TOFU
- Unterlasse nichtssagende Antworten wie "Danke" oder "werde ich mal testen" oder ähnliches, sofern Du nicht der Threadersteller bist und einen Lösungsvorschlag angeboten bekommen hast.
- Vermeide Doppel-Posts (zwei Beiträge von Dir hintereinander) sondern editiere wenn möglich Deine Posts.

Danke...

  • MJPG-Streamer geht nicht im MJPG Format

    Hi,
    die Installation des MJPG-Streamers ist bei mir ohne Fehler gelaufen. Aber leider kann ich das Bild (den Stream) nicht im MJPG Format anzeigen. Es geht nur im YUV Format (aber dann ist die CPU Last auf fast 90 %).
    Es passt scheinbar was nicht mit dem Patch. Aber ich bekomme keinen Fehler beim patchen. Wie kann ich rausfinden was da nicht passt?
    Brauch dringen Eure Hilfe!! ;(

    Hab das Problem gelöst: Patch mit -R deinstalliert und neu aktiviert.

    The post was edited 2 times, last by SirIcy: Problem gelöst! ().

  • Ansgar
    Hallo
    stehe gerade vor der mjpg Installation, vor Tagen schon mal Probleme und dann frustriert abgebrochen.
    Im fhem Forum schrieb mir dann jemand das der Patch für eine ältere Version ist, hab aber genau nach der Anleitung hier auf einem frischen System installiert und hatte glaube ich Version 182

    mit Welchem genuaen Kommando geht das?
    aber von input_uvc_patch.txt in input_uvc_patch umbenennen.

    stehe noch mit Linux auf Kriegsfuss
  • Hi Franz,

    kein Grund frustiert zu sein ^^
    Die Linux Befehle kannst du alle googlen.

    Ich versuche mal eine kleine Anleitung:
    1. Die Datei (input_uvc_patch.txt) im Anhang runterladen.
    2. Die Datei auf den Pi übertragen ins Verzeichnis "/home/pi/mjpg-streamer-code/mjpg-streamer". Dazu kann man z.B. FileZilla nehmen.
    3. Ins richtige Verzeichnis gehen mit: cd /home/pi/mjpg-streamer-code/mjpg-streamer
    4. Prüfen, dass die Datei input_uvc_patch.txt da ist mit: ls input*
    5. Die Patch-Datei umbenennen mit: mv input_uvc_patch.txt input_uvc_patch
    6. Dann den Patch ausführen mit: patch -p0 < input_uvc_patch
    7. Weiter in der Anleitung "Installation Software MJPG-Streamer"

    Dann läuft es! Hab's jetzt schon ein paar Mal gemacht und Übung macht den Meister :D

    VG
    SirIcy

    The post was edited 2 times, last by SirIcy ().

  • es läuft
    hab alle Schritte noch mal gemacht
    warum es nun aber funktioniert hat ????????
    egal

    sehe nun im win Browser

    About
    Details about the M-JPEG streamer
    Congratulations



    wenn ich dann aber den Linkin den Browser kopiere
    door:9000/?action=stream
    sehe ich nur noch schwarz









    bin schon weiter gekommen, der Patch ist irgendwie dann doch jetzt drin...
    schreibe gerade eine Anleitung für das ganze doorpi Projekt für dummies wie mich
    hier veröffentlicht:
    forum.fhem.de/index.php?topic=71388.msg629839#msg629839
    möchte das Ganze überFHEM machen undintegrieren

    versuche gerade alles in die autostart zubekommen
    da aber auch wieder Probleme
    hab diese Anleitung genommen.

    Installation des mjpg-streamer.

    pi@Door:~ $ sudo nano /etc/init.d/mjpg_streamer

    hier alles eingefügt was einzufügen ist
    dann das hier:
    pi@Door:~ $ sudo update-rc.d mjpg_streamer defaults
    insserv: script mjpg_streamer is not an executable regular file, skipped!

    und dann kommt die obige Fehlermeldung, wieder was faul
    grrr

    dies eingefügt und dann gespeichert:
    wie nur bekomme ich nun den gesamten Text aus dem Editor. :(


    so gerade dasmit dem patch versucht
    mit filezilla zum raspi kopiert Berechtigungen auf voll gesetzt ( im 2. Versucht )
    dort findet sich neben der
    input_uvc_patch.txt
    auch eine
    input_uvc_patch

    wenn ich das dann nach deiner Anleitung weiter mache kommt das hier:
    pi@Door:~ $ sudo mv input_uvc_patch.txt input_uvc_patch
    mv: der Aufruf von stat für „input_uvc_patch.txt“ ist nicht möglich: Datei oder Verzeichnis
    nicht gefunden

    The post was edited 2 times, last by FranzT: Erfolg ! weitere Versuche ().

  • wenn du den Befehl
    "mv input_uvc_patch.txt input_uvc_patch"
    eingibst, bist du dann im richtigen Verzeichnis?

    Sonst gib ein:
    cd /home/pi/mjpg-streamer-code/mjpg-streamer

    Dann: ls input*
    Hier muss die input_uvc_patch.txt gelistet werden.

    Dann gebe ein:
    mv input_uvc_patch.txt input_uvc_patch

    Dann wieder: ls input*
    Jetzt sollte die Datei input_uvc_patch gelistet werden.

    Dann weiter mit der Anleitung

    The post was edited 2 times, last by SirIcy ().

  • das klappt ja nun
    auch autostart

    das bekomme ich mit status, hab ich einfach mal probiert, stand zwar nicht in der
    Anleitung

    pi@Door:~ $ sudo service mjpg_streamer status
    ● mjpg_streamer.service - LSB: MJPG_Streamer_autostart
    Loaded: loaded (/etc/init.d/mjpg_streamer)
    Active: active (running) since Mi 2017-05-03 19:08:27 CEST; 25min ago
    Process: 361 ExecStart=/etc/init.d/mjpg_streamer start (code=exited, status=0/SUCCESS)
    CGroup: /system.slice/mjpg_streamer.service
    └─390 /usr/local/bin/mjpg_streamer -i /usr/local/lib/input_uvc.so -d /dev/video0 -n -r 1024x768 -f 24 q 8...

    Mai 03 19:08:26 Door mjpg_streamer[390]: MJPG-streamer [390]: Desired Resolution: 1024 x 768
    Mai 03 19:08:26 Door mjpg_streamer[390]: MJPG-streamer [390]: Frames Per Second.: 24
    Mai 03 19:08:26 Door mjpg_streamer[390]: MJPG-streamer [390]: Format............: MJPEG
    Mai 03 19:08:26 Door mjpg_streamer[390]: MJPG-streamer [390]: www-folder-path...: /usr/local/www/
    Mai 03 19:08:26 Door mjpg_streamer[390]: MJPG-streamer [390]: HTTP TCP port.....: 9000
    Mai 03 19:08:26 Door mjpg_streamer[390]: MJPG-streamer [390]: username:password.: disabled
    Mai 03 19:08:26 Door mjpg_streamer[390]: MJPG-streamer [390]: commands..........: disabled
    Mai 03 19:08:26 Door mjpg_streamer[390]: MJPG-streamer [390]: starting input plugin /usr/local/lib/input_uvc.so
    Mai 03 19:08:26 Door mjpg_streamer[390]: MJPG-streamer [390]: starting output plugin: /usr/local/lib/output_http...: 00)
    Mai 03 19:08:27 Door systemd[1]: Started LSB: MJPG_Streamer_autostart.
    Hint: Some lines were ellipsized, use -l to show in full.


    wenn ich dann aber im vlc player das hier eingebe:
    door:9000/?action=stream

    passiert noch nichts

    The post was edited 1 time, last by FranzT: da fehlte am ende was ().

  • ja hatte ganz am Anfang hiermit
    raspivid -o - -t 0 -n | cvlc -vvv stream:///dev/stdin --sout '#rtp{sdp=rtsp://:8554/}' :demux=h264
    auch ein Bild im Browser

    mit deinen Tips und weil ich die ganz mjpg INstall dann ncoh mal neu gemacht habe und dann hinter dem eigentlichen patch noch deinen aufgerufen habe ging alles,
    der streamer scheint ja auch richtig installiert zu sein

    es fehlt halt nur noch ein Bild im Browser oder im VLC Player,
    dachte aber man kann ein Videobild im Browser zeigen
  • Moin,

    ich bekomme das Bild im Browser angezeigt, alles kein Problem. Jetzt verzweifel ich schon seit Tagen daran, dass mir das Bild einfach nicht über die Friite aufs Fritzfon übertragen wird. Wenn ich manuell am Fritfon aufrufe, habe ich ein Bild, nur nicht beim Klingel.....

    Kleiner Ausschnitt meiner doorpi.ini:

    [SIP-Phone]
    firewallpolicy = PolicyNoFirewall
    audio_codecs = PCMA,PCMU
    call_timeout = 30
    capture_device = ALSA: USB Audio Device
    dialtone = !BASEPATH!/media/Tuer.wav
    dialtone_renew_every_start = false
    dialtone_volume = 30
    mic_gain_db = 3
    echo_cancellation_enabled = true
    identity = Haustuer
    local_port = 5060
    max_call_time = 120
    playback_device = ALSA: USB Audio Device
    record_while_dialing = false
    records = !BASEPATH!/records/%Y-%m-%d_%H-%M-%S.wav
    sipphonetyp = linphone
    sipserver_password = ************
    sipserver_realm = fritz.box
    sipserver_server = 192.168.1.33
    sipserver_username = Klingel625
    ua.max_calls = 2
    stun_server =
    video_codecs = VP8
    video_device = Static picture
    video_display_enabled = true
    video_size = vga

    Das Klingelevent wird natürlich auch ausgelöst :)

    Kann jemand bitte helfen ?

    danke und Gruß

    The post was edited 1 time, last by Atze68 ().

  • Die doorpi.ini hat nichts damit zu tun.
    Falls doch, steht das bei mir drin:

    Source Code

    1. ua.max_calls = 2
    2. video_codecs = VP8
    3. video_device = StaticImage: Static picture
    4. video_display_enabled = False
    5. video_size = vga
    Bei mjpg-streamer das in die Fritzbox eintragen :

    Source Code

    1. 192.168.xxx.xxx:xxxx/?action=snapshot.jpg
    Gruß
    Wal

    Kaum macht man es richtig, funktioniert es auch !
  • Hallo Wal, zunächst mal vielen Dank für die Antwort.
    Genau da scheint der Hund begraben zu sein.... Meine Video- Datei heißt: 2018-10-23_16-19-41.jpg bzw. fortlaufend.
    Ich habe bis jetzt noch keine Möglichkeit gefunden, den Namen zu ändern, liegt da irgendwo versteckt eine Config- Datei ?
    Das Event habe ich so geschrieben, inkl. einer Datei, dass wenn jemand die Klingel betätigt, wird ein Video aufgenommen, bis man am Fritzfon auflegt. Dann wird auch automatisch die Datei gelöscht.

    10 = os_execute:/home/pi/bin/motion_encode_and_delete_jpgs.sh
    20 = sleep:0.5
    30 = file_call_value:/usr/local/etc/DoorPi/Erdgeschoss.txt
    40 = out:Klingel,1,0,4
    50 = take_snapshot:192.168.1.198:8081/?action=snapshot

    Hast du eine Idee ?

    Danke und Gruß, Atze

    The post was edited 1 time, last by Atze68 ().