Live-Bild für FRITZ! Fon

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

Da in jedem Forum ein paar Regeln eingehalten werden müssen, möchte ich diese auch vorher hier festlegen und niederschreiben. Die grundsätzliche Netiquette setze ich bei Jedem voraus. Darüber hinaus möchte ich nur spezielle Regeln ansprechen:
- Unterlasse FullQuote sondern nutze Alternativen wie Inline-Quoting
-> siehe auch https://de.wikipedia.org/wiki/Fullquote vs. https://de.wikipedia.org/wiki/TOFU#Alternativen_zu_TOFU
- Unterlasse nichtssagende Antworten wie "Danke" oder "werde ich mal testen" oder ähnliches, sofern Du nicht der Threadersteller bist und einen Lösungsvorschlag angeboten bekommen hast.
- Vermeide Doppel-Posts (zwei Beiträge von Dir hintereinander) sondern editiere wenn möglich Deine Posts.

Danke...

  • Hallo Leute,

    erst einmal ein Lob an die Mitwirkenden dieses Boards, es ist sehr Informel und Hilfreich.

    ich habe jetzt ca. 2 Wochen gelesen und gelesen und mich entschlossen auch eine Türsprechanlage in Verbindung mit dem Raspberry zu realisieren.

    angefangen habe ich erst mal mit 3 Komponenten;

    RasperryPi 3
    RaspiCam
    PiFace

    Installation der DoorPI nach Anleitung vom Board - abgeschlossen - laüft
    Installation mjpg streamer - abgeschlossen - laüft
    Anbindung Fritzbox 7490 - abgeschlossen - laüft
    SipServer - abgeschlossen - laüft

    aber was ich absolut nicht auf die Reihe bekomme ist; das Live-Bild für FRITZ! Fon wie von Markus beschrieben weiter oben.

    Taster drücken auf dem PiFace - Fritzfon MF klingelt - Bild wird erwartet - Bild ist nicht länger verfügbar
    auch nach langem lesen im Board habe ich leider keine Lösung gefunden, ich muss aber auch dazu sagen das ich kein Programmierer bin
    und mich auch nicht mit Phyton auskenne.

    Ich hoffe das mir einer von euch weiterhelfen kann, danke erst mal.
  • Hallo Mirk,

    Mirk wrote:

    Taster drücken auf dem PiFace - Fritzfon MF klingelt - Bild wird erwartet - Bild ist nicht länger verfügbar
    ich habe eigentlich die gleiche Hardware am laufen und bei mir funzt das Livebild am Fritz!Fon C5 sehr gut.

    Um dir evtl. helfen zu können, wären erstens deine sonstigen Einstellungen im DoorPi (Doorpi.ini) bzw. die in der Fritzbox wichtig zu wissen und zweitens ob du den Livestream über den Browser siehst.

    Gruß

    Albundy
  • Servus,

    danke für die schnelle Antwort, es gibt von den Fritzfon`s ja vier Stück: das M2, C4, MT-F und das C5. Ich habe gedacht das es eventuell daran liegt das ich das MT-F habe, aber das wahr leider nicht so. Habe mir heute ein C5 geholt und habe die selben Probleme wie oben stehend.

    Anbei meine Einstellungen der FritzBox, Einstellungen der doorpi.ini und das trace.log

    Den LiveStream sehe ich über den Browser, das funktioniert gut.

    Ich denke es ist eher ein Konfigurationsfehler meinerseits, schaut euch doch mal bitte wie eure Zeit es erlaubt die Dateien an und gebt mir einen guten Rat wo ich da die Fehler gemacht habe.

    danke euch
    Images
    • Einstellung_FritzBox.JPG

      205.13 kB, 2,134×1,103, viewed 238 times
    Files
    • tracelog.txt

      (480.73 kB, downloaded 155 times, last: )
  • Servus,

    ich habe jetzt mal die komplette Installation auf einer anderen SD Karte gemacht, das heist ich habe nach jedem eingegebenen Befehl einen reboot gemacht.
    Am ende wo ich fertig war und ich auf den Taster gedrückt habe hat das Live Bild funktioniert, fragt mich bitte nicht warum.

    Aus Interesse werde ich mal die Trace.log`vergleichen um zu wissen warum.

    allen noch einmal Danke für die Unterstützung und Hilfe.

    Mirk
  • Hallo zusammen,
    ich muß mich mal einklinken. Ich doktore schon ca. 3 Wochen am Doorpi. Mitlerweile glaube ich vieles verstanden zu haben aber halt nicht alles.
    Ich bekomme auf meinem Fritzfon C5 nur Bilder über "http://ip_des_pi:9000/?action=snapshot" hin. Über "http://ip_des_pi:9000/?action=stream" sagt, dass das c5 das Bildformat nicht unterstützt.
    Ist das normal oder habe ich etwas falsch installiert ?? Auf dem PC läuft alles blendend. Dateiformat ist mjpeg. AVM sagt die unterstützen das Bildformat. Bin ratlos und suche hier Hilfe ?( .


    Gruß

    Chris
  • Hi,

    Ich betreibe 2 FritzFon C4 und ein C5 an der Fritzbox (MJPG Streamer Aufruf über http).
    Dabei habe ich das Problem, dass das Live-Bild beim Anruf von meinem DoorPi erst nach ca. 10 sec angezeigt wird. Bis ich sehe wer da ist, ist der Postbote schon wieder weg ;(
    Wenn ich das Live-Bild direkt vom Fritzfon aufrufe, wird es nach 4 bis 5 sec angezeigt. Im Browser (egal ob über LAN oder WLAN) erscheint der Snapshot oder der Stream sofort ohne ersichtlicher Verzögerung.
    Ein weiteres Problem ist, dass beim Anruf vie IP-TFE das Bild nicht gedreht werden kann. Das geht nur bei Aufruf des Live-Bilds über Fritzfon.

    Der AVM Support meint:
    "Das FRITZ!Fon ist über den sehr energiesparenden und weniger störungsanfälligen Standard "DECT-GAP" mit der FRITZ!Box verbunden.
    Dieser Standard hat allerdings eine geringere Übertragungsgeschwindigkeit als WLAN. Dadurch ist eine schnelle Akutualisierung des Live-Bild, inbs. während eines Telefonats, nicht möglich."

    Die Übertragung ist aber immer gleich langsam auch wenn ich eine ganz kleine Bilddatei am Fritzfon über ftp als Live-Bild anzeigen lasse.

    Wie lange dauert die Anzeige des Live-Bilds bei Euch so?

    VG
    Icy
  • Hi Franz,
    ich hab in deinem Thread nur gefunden, dass du das Bild im Streamer um 90 Grad drehst, weil deine Kamera um 90 Grad gedreht ist. Meinw Kamera ist aber gerade. Das Problem ist, dass im Fritzfon das Bild im Hochformat statt Querformat angezeigt wird und dabei die Ränder abgeschnitten werden. Ich möchte das Bild im Fritzfon drehen, damit es im richtigen Format angzeigt wird.
    By the way: 5 Sek sind schon ganz schön lang...
  • Hi,

    bei mir dauert es auch um die 4-5 Sekunden. Allerdings hatte ich am Anfang ähnliche Probleme, ich konnte allerdings verschiedene Qualitäten des Streams über http aufrufen.

    Was dann das Problem gelöst hatte, am Anfang hatte ich auch um die 8 bis 10 Sekunden. Da ich den gleichen Stream nutzte der auch von meiner synology aufgezeichnet wurde.

    Zur Grösse des Bildes, ich bin mir jetzt nicht ganz sicher aber kann man das nicht auch über den Stream festlegen. Also bei mir ist jetzt Stream 1 für meine synology (hohe Auflösung) und Stream 2 für die FritzBox mit der passenden Grösse.

    Gruss Mike



    Gesendet von meinem SM-G950F mit Tapatalk

    The post was edited 1 time, last by Mikeldk ().