Soundkarte funktioniert nicht

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

Da in jedem Forum ein paar Regeln eingehalten werden müssen, möchte ich diese auch vorher hier festlegen und niederschreiben. Die grundsätzliche Netiquette setze ich bei Jedem voraus. Darüber hinaus möchte ich nur spezielle Regeln ansprechen:
- Unterlasse FullQuote sondern nutze Alternativen wie Inline-Quoting
-> siehe auch https://de.wikipedia.org/wiki/Fullquote vs. https://de.wikipedia.org/wiki/TOFU#Alternativen_zu_TOFU
- Unterlasse nichtssagende Antworten wie "Danke" oder "werde ich mal testen" oder ähnliches, sofern Du nicht der Threadersteller bist und einen Lösungsvorschlag angeboten bekommen hast.
- Vermeide Doppel-Posts (zwei Beiträge von Dir hintereinander) sondern editiere wenn möglich Deine Posts.

Danke...

  • Soundkarte funktioniert nicht

    Hallo
    Ich komme einfach nicht weiter. Vielleicht habt ihr eine Idee.
    Das ganze läuft auf einem pi3,
    wenn ich denn Taster am piface drücke läutet das Telefon aber keine Sprachübertragung.
    Generel habe ich keine audioausgabe.
    Hier noch die ausgaben über putty:


    Source Code

    1. pi@DoorPi:~ $ mplayer /home/doorpi/sounds/bigben_mono.wav
    2. MPlayer 1.3.0 (Debian), built with gcc-6.2.1 (C) 2000-2016 MPlayer Team
    3. do_connect: could not connect to socket
    4. connect: No such file or directory
    5. Failed to open LIRC support. You will not be able to use your remote control.
    6. Playing /home/doorpi/sounds/bigben_mono.wav.
    7. libavformat version 57.56.101 (external)
    8. Mismatching header version 57.56.100
    9. Audio only file format detected.
    10. Load subtitles in /home/doorpi/sounds/
    11. ==========================================================================
    12. Opening audio decoder: [pcm] Uncompressed PCM audio decoder
    13. AUDIO: 44100 Hz, 1 ch, s16le, 705.6 kbit/100.00% (ratio: 88200->88200)
    14. Selected audio codec: [pcm] afm: pcm (Uncompressed PCM)
    15. ==========================================================================
    16. AO: [pulse] Init failed: Connection refused
    17. Failed to initialize audio driver 'pulse'
    18. [AO_ALSA] Playback open error: No such file or directory
    19. Failed to initialize audio driver 'alsa'
    20. [AO SDL] Samplerate: 44100Hz Channels: Mono Format s16le
    21. [AO SDL] using aalib audio driver.
    22. [AO SDL] Unable to open audio: No available audio device
    23. Failed to initialize audio driver 'sdl:aalib'
    24. Could not open/initialize audio device -> no sound.
    25. Audio: no sound
    26. Video: no video
    27. Exiting... (End of file)
    Display All

    Source Code

    1. pi@DoorPi:~ $ cat /proc/asound/cards
    2. 1 [Device ]: USB-Audio - USB Audio Device
    3. GeneralPlus USB Audio Device at usb-3f980000.usb-1.4.1, full speed
    4. 2 [ALSA ]: bcm2835 - bcm2835 ALSA
    5. bcm2835 ALSA


    Source Code

    1. pi@DoorPi:~ $ lsusb
    2. Bus 001 Device 006: ID 2341:8037 Arduino SA
    3. Bus 001 Device 005: ID 1b3f:2008 Generalplus Technology Inc.
    4. Bus 001 Device 004: ID 0424:2422 Standard Microsystems Corp.
    5. Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
    6. Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
    7. Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    pi@DoorPi:~ $ sudo nano ~/.asoundrc

    Source Code

    1. pcm.!default {
    2. type hw
    3. card 0
    4. }
    5. ctl.!default {
    6. type hw
    7. card 0
    8. }

    Gruß Markus
  • Danke für die Hilfe

    doorpi.pni

    Source Code

    1. capture_device=ALSA: USB Audio Device
    2. playback_device=ALSA: USB Audio Device
    3. #
    4. audio_codecs = PCMA,PCMU
    5. record_while_dialing = False
    6. records = /home/doorpi/records/%Y-%m-%d_%H-%M-%S.wav
    7. #
    8. dialtone = /home/doorpi/sounds/bigben_mono.wav
    9. dialtone_renew_every_start = False
    10. dialtone_volume = 35
    11. echo_cancellation_enabled = False
    12. #
    13. video_codecs = VP8
    14. video_device = StaticImage: Static picture
    15. video_display_enabled = False
    16. video_size = vga
    Display All
    dmesg | grep usb


    Source Code

    1. pi@DoorPi:~ $ dmesg | grep usb
    2. [ 0.152155] usbcore: registered new interface driver usbfs
    3. [ 0.152258] usbcore: registered new interface driver hub
    4. [ 0.152373] usbcore: registered new device driver usb
    5. [ 0.315517] usbcore: registered new interface driver smsc95xx
    6. [ 0.788350] dwc_otg 3f980000.usb: DWC OTG Controller
    7. [ 0.790687] dwc_otg 3f980000.usb: new USB bus registered, assigned bus number 1
    8. [ 0.793050] dwc_otg 3f980000.usb: irq 62, io mem 0x00000000
    9. [ 0.800014] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
    10. [ 0.802351] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
    11. [ 0.804661] usb usb1: Product: DWC OTG Controller
    12. [ 0.806911] usb usb1: Manufacturer: Linux 4.9.41-v7+ dwc_otg_hcd
    13. [ 0.809181] usb usb1: SerialNumber: 3f980000.usb
    14. [ 0.817472] usbcore: registered new interface driver usb-storage
    15. [ 0.850537] usbcore: registered new interface driver usbhid
    16. [ 0.853000] usbhid: USB HID core driver
    17. [ 1.230505] usb 1-1: new high-speed USB device number 2 using dwc_otg
    18. [ 1.460801] usb 1-1: New USB device found, idVendor=0424, idProduct=9514
    19. [ 1.463385] usb 1-1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
    20. [ 1.790511] usb 1-1.1: new high-speed USB device number 3 using dwc_otg
    21. [ 1.920804] usb 1-1.1: New USB device found, idVendor=0424, idProduct=ec00
    22. [ 1.920813] usb 1-1.1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
    23. [ 2.025984] smsc95xx 1-1.1:1.0 eth0: register 'smsc95xx' at usb-3f980000.usb-1.1, smsc95xx USB 2.0 Ethernet, b8:27:eb:09:26:03
    24. [ 2.130522] usb 1-1.4: new high-speed USB device number 4 using dwc_otg
    25. [ 2.270833] usb 1-1.4: New USB device found, idVendor=0424, idProduct=2422
    26. [ 2.273642] usb 1-1.4: New USB device strings: Mfr=0, Product=0, SerialNumber=0
    27. [ 2.610566] usb 1-1.4.1: new full-speed USB device number 5 using dwc_otg
    28. [ 3.259552] usb 1-1.4.1: New USB device found, idVendor=1b3f, idProduct=2008
    29. [ 3.259568] usb 1-1.4.1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
    30. [ 3.259576] usb 1-1.4.1: Product: USB Audio Device
    31. [ 3.259584] usb 1-1.4.1: Manufacturer: GeneralPlus
    32. [ 3.265711] input: GeneralPlus USB Audio Device as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.4/1-1.4.1/1-1.4.1:1.3/0003:1B3F:2008.0001/input/input0
    33. [ 3.331045] hid-generic 0003:1B3F:2008.0001: input,hidraw0: USB HID v2.01 Device [GeneralPlus USB Audio Device] on usb-3f980000.usb-1.4.1/input3
    34. [ 3.430564] usb 1-1.4.2: new full-speed USB device number 6 using dwc_otg
    35. [ 3.577420] usb 1-1.4.2: New USB device found, idVendor=2341, idProduct=8037
    36. [ 3.577437] usb 1-1.4.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    37. [ 3.577445] usb 1-1.4.2: Product: Arduino Micro
    38. [ 3.577453] usb 1-1.4.2: Manufacturer: Arduino LLC
    39. [ 3.658373] usbcore: registered new interface driver snd-usb-audio
    40. [ 4.016827] usbcore: registered new interface driver cdc_acm
    41. [ 4.097789] usbcore: registered new interface driver brcmfmac
    42. pi@DoorPi:~ $ ^C
    Display All
    Edit: log Gelöscht

    The post was edited 1 time, last by Markus1 ().

  • Hallo Markus,

    die LOG-Datei und Konfig sieht IMHO eigentlich ganz gut aus.

    Da fällt mir auch nicht mehr viel zu ein.

    Alle "Kanäle" der Soundkarte eingeschaltet?
    sudo alsamixer; Mit F6 Soundkarte auswählen + Enter; Mit F5 alle "Kanäle" anschauen.



    Für den Anfang muss überall "00" stehen (Auswahl mit Cursor-Tasten; Ändern mit "m") und den "Pegel" hoch drehen (Mit Rauf/Runter)

    Sonst die Hardware (Leitungen, Lautsprecher, Mikro) noch mal woanders testen. Am PC oder so.

    Viele Grüße
    Olaf
    Images
    • Bildschirmfoto zu 2017-12-31_13-42-01.png

      37.33 kB, 669×376, viewed 84 times
    --
    Wer nicht gekennzeichnete Rechtschreibfehler findet darf sie gerne behalten.
  • Hallo Markus,

    Markus1 wrote:

    wen ich

    Source Code

    1. aplay /home/doorpi/sounds/bigben_mono.wav
    eingebe spielt der raspberry 3 über klinke ab
    Dann läuft die Soundkarte ja erst einmal. :thumbup:

    IMHO liegt es wohl zwischen DoorPi und Fritzbox. Von der Fritzbox habe ich nicht so den Plan.

    Rufnummer "**2" ist richtig? Muss da nicht die "11" (call:11) oder so angerufen werden?

    Viele Grüße
    Olaf
    --
    Wer nicht gekennzeichnete Rechtschreibfehler findet darf sie gerne behalten.
  • Frohes neues Jahr,

    Markus1 wrote:

    Nein die bordeigene Soundkarte des Rasperi 3 spielt den sound ab ich bekomme ihn auch nicht auf die usb soundkarte ausgegeben.
    Ahh, OK. Schade.
    Dann mal horchen, ob bei speaker-test -c 2 -D hw:1 ein Rauschen zu hören ist.

    Markus1 wrote:

    Wenn ich den taster drücke leutet das Telefon also kann es doch auch nicht an der fritzbox liegen, oder doch?
    Stimmt. Hatte ich verdrängt, dass "nur" kein Sound raus kommt aber das Telefon klingelt.


    Viele Grüße
    Olaf
    --
    Wer nicht gekennzeichnete Rechtschreibfehler findet darf sie gerne behalten.
  • Markus1 wrote:

    Ich habe jetzt das rauschen auf den USB Lautsprecher aber der ton vom Telefon kommt nicht an.
    Dann läuft die USB-Soundkarte auch :thumbup:

    Markus1 wrote:

    Ich habe jetzt die Primäre Soundkarte in alsa auf usb umgestelt.
    Dann sollte aplay auch "normal" über usb funktionieren.
    (Z.B. aplay /usr/local/lib/python2.7/dist-packages/linphone/unittests/sounds/ahbahouaismaisbon.wav
    Gibt schon bekloppte Sounds ...)


    Vielleicht liegt es dann an den Ports welche für RTP benötigt werden?

    Irgend etwas zwischen DoorPi und Fritzbox geschaltet? Firewall, Router, ...
    DoorPi hängt am Gastnetz der Fritzbox? (Ich weiß allerdings nicht, ob das eine Rolle spielt)
    Oder ein Doorpi in der Fritzbox nochmal einrichten ...

    Viele Grüße
    Olaf
    --
    Wer nicht gekennzeichnete Rechtschreibfehler findet darf sie gerne behalten.