Neues DoorPI Projekt


  • stonev :
    Kannst Du bitte mal den entsprechenden Auszug aus deiner doorpi.ini hier posten? Hab das Gefühl, daß damit was nicht ganz stimmt?!


    Bitteschön:


    /etc/modprobe.d/snd_bcm2835.conf ...


    Habe ich aufgrund des o. a. Post von Joker angelegt. Hatte es aber auch mit der blacklist.conf versucht. Das Ergebnis war bei mir in beiden Fällen gleich. Die USB Soundkarte wurde erkannt und war auch das einzige Sound Device - soweit gut. Der Sound-Test


    Code
    1. speaker-test -D hw:1 -c 2


    funktionierte. Die Konfiguration funktionierte also unter Jessie.


    Mit

    Code
    1. aplay -L


    wurde die USB Karte als Alsa Gerät angezeigt.


    der Alsamixer wurde komischerweise nicht mehr gefunden und gestartet. Und über den DoorPi kam auch kein Ton.

  • Also das ist jetzt nur noch stochern im Nebel, aber... alsamixer liegt normalerweise im Verzeichnis /usr/bin.
    Liegt er dort bei dir?


    Wenn nicht könntest Du ja die alsa-utils mal neu installieren (dort gehört der alsamixer dazu).


    Code
    1. sudo apt-get remove alsa-utils
    2. sudo apt-get install alsa-utils
  • Hast Recht, das ist stochern im Nebel. Vor allem weil es vorher ja auch funktionierte.
    Reinstalltion der alsa-utils hat übrigens auch nicht funktioniert. Nach dem Löschen funktionierte eine Neuinstalltion mit der blacklist nicht. Lies erst wieder installieren, nachdem ich die blacklist wieder gelöscht hatte.


    Ich steck da erst mal keine Energie mehr rein. Vielleicht ergibt sich später ja noch mal was.


    Wichtiger ist es, Mikrofon und LS akkustisch zu entkoppeln, um die Sprachqualität beim Gegensprechen zu erhöhen.
    Wirklich zufrieden stellt mich die Sprachqualität derzeit nicht... Muss da noch ein wenig experimentieren.


    Bietet linphone noch Möglichkeiten softwareseitig an der Sprachqualität zu schrauben?

  • Habe mal das deaktivieren vom snd_bcm2835 Modul nachgestellt. Das Problem ist, das es danach keine Soundkarte 0 mehr gibt und deshalb ein alsamixer nichts findet.
    Machst du ein alsamixer -c1 funktioniert er. Trage ich die Änderung in [font=Consolas, Menlo, Monaco,]/etc/asound.conf ein wie unter http://superuser.com/questions…ound-device-automatically beschrieben funktioniert alsamixer ohne "-c1" , da ich damit sage das Soundkarte 1 meine "default" ist, Doorpi geht aber damit nur teilweise. Ich denke man muß es hinbringen, das der USB-Stick Soundkarte 0 wird.[/font]
    [hr]
    Ich nochmal :D
    weiter unten im Link, ist die Lösung:


    [font=Arial,]nano /etc/modprobe.d/alsa-base.conf[/font]
    [font=Arial,]options snd_usb_audio enable=1 index=0


    eintragen und gut ist es.[/font]


    [font=Arial,]Änderung in [font=Consolas, Menlo, Monaco,]/etc/asound.conf wieder rückgängig machen, nicht vergessen![/font][/font]

    Gruß
    Wal


    Kaum macht man es richtig, funktioniert es auch !

    Einmal editiert, zuletzt von Wal ()


  • Wichtiger ist es, Mikrofon und LS akkustisch zu entkoppeln, um die Sprachqualität beim Gegensprechen zu erhöhen.
    Wirklich zufrieden stellt mich die Sprachqualität derzeit nicht... Muss da noch ein wenig experimentieren.


    Interessiert mich auch brennend, ich mache mal ein neues Thema dafür auf, denn sonst findet man das später nicht wieder und ich denke es ist wichtig.

  • Versucht mal das hier:





    Als Erstes alles auf den neuesten Stand bringen.


    sudo apt-get update
    sudo apt-get upgrade



    USB Soundkarte


    Mit aplay -l die „Liste der Hardware Geräte“ anzeigen.


    pi@raspberrypi ~ $ aplay -l
    **** Liste der Hardware-Geräte (PLAYBACK) ****
    Karte 0: ALSA [bcm2835 ALSA], Gerät 0: bcm2835 ALSA [bcm2835 ALSA]
    Sub-Geräte: 8/8
    Sub-Gerät #0: subdevice #0
    Sub-Gerät #1: subdevice #1
    Sub-Gerät #2: subdevice #2
    Sub-Gerät #3: subdevice #3
    Sub-Gerät #4: subdevice #4
    Sub-Gerät #5: subdevice #5
    Sub-Gerät #6: subdevice #6
    Sub-Gerät #7: subdevice #7
    Karte 0: ALSA [bcm2835 ALSA], Gerät 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]
    Sub-Geräte: 1/1
    Sub-Gerät #0: subdevice #0
    Karte 1: Device [USB Audio Device], Gerät 0: USB Audio [USB Audio]
    Sub-Geräte: 1/1
    Sub-Gerät #0: subdevice #0



    Bei mir wird die USB Soundkarte als Karte 1 angezeigt.


    Folgendes bitte in der alsa.conf ändern.


    sudo nano /usr/share/alsa/alsa.conf


    dort die Einträge


    defaults.ctl.card 0
    defaults.pcm.card 0


    suchen und hier nun die 2. Soundkarte eintragen, also card 1. Card 0 ist ja wieder die interne Soundkarte.


    defaults.ctl.card 1
    defaults.pcm.card 1



    Jetzt noch einen reboot


    sudo reboot


    und als nächstes


    aplay /usr/share/sounds/alsa/Front_Center.wav


    Und sich freuen das es aus der richten Soundkarte kommt.

  • Ich bekomme es einfach nicht hin. Es kommt weder Ton , noch geht mein Mikro.
    Was ist, wenn bei mir nur eine Karte angezeigt wird, diese card 0 ist und das meine USB Soundkarte ist?


    card 0: Device [USB Audio Device], device 0: USB Audio [USB Audio]
    Subdevices: 1/1
    Subdevice #0: subdevice #0

  • Hallo,


    kann sein, das eine onboard Sound in der Blacklist steht. Schau mal in /etc/modprobe.d/raspi-blacklist.conf nach ob da "blacklist snd_bcm2835" eingetragen ist. Wenn ja, raus und neu starten.


    jm


    ach ja... und in der raspi-config mal das Audio Device auf 3,5mm Klinke setzen.

  • Hallo muellerjm,


    ich spiele gerade wieder mein backup drauf, welches ich erstellt habe, nachdem ich doorpi + mpgstream eingestellt habe. Allerdings funktioniert da der sound auch noch nicht.
    Die ganzen Anleitungen sind leider alle veraltet. In der Zwischenzeit hat sich sehr viel getan :(