Wie Verstärker mit Spannung versorgen?

  • Hallo zusammen,


    eigentlich dachte ich, es wäre ganz einfach, den Verstärker anzuschließen und beim Tastendruck des Klingeltasters mit Strom zu versorgen. Aber ich scheitere schon eine Stufe vorher.


    Ich habe die kleine rote Verstärkerplatine von Foxnovo. Ich habe einen 3,5mm Klinkenstecker mit Kabel an den Eingang des Verstärkers gelötet. Dieser steckt im Ausgang der Soundkarte. Wenn ich nun den Verstärker mit 5V versorge (ersteinmal unabhängig vom Tastendruck), dann wird der Verstärker sofort aktiv und spielt wie erwartet Sound bei Tastendruck ab.


    Nun möchte ich aber erreichen, dass der Verstärker erst aktiv wird, wenn der Klingeltaster gedrückt wird. Die Events in der DoorPi.ini funktionieren, jedoch weiß ich nicht, wo ich nun GND und +5V des Verstärkers anschließe. Ich hätte eigentlich gedacht, dass ich die 5V an den 5V Ausgang des PiFace anschließe und GND z.B. an Ausgang 2. Hier habe ich aber das Problem, dass der Verstärker sofort angeht, wenn ich nur 5V anlege.


    Kann mir jemand weiterhelfen?


    Danke und Gruß,
    DerStandart

  • Dieser Verstärker hat einen Eingangskontakt "SW". Wenn man den auf 0=GND legt, zieht er keinen Strom mehr und bleibt still.


    Bei mir geht dient ein Ausgang des PiFace dafür, das "dashlight" = Armaturenbrettbeleuchtung = Leuchte Klingeltaster und Display auf volle Helligkeit zu schalten. Ein MOSFET 2N7000 dazwischen, und schon schaltet der auch den Verstärker an (MOSFET wirkt als Inverter).


    Problem: Der Verstärker braucht ca. 1 s, um in Gang zu kommen. Also ERST dashlight on, dann Durchsage machen.


    LG


    pah

  • Hey,
    Nein das ist nicht unbedingt falsch. Der Verstärker zieht sich nun die Masse vom 3,5 Klinke über die Soundkarte.


    Schaue mal bitte ob Du die Masse und der + am Audio Eingang des Verstärkers nicht vertauscht hast. Das war bei mir der Fall.

  • Der Vorteil des internen "SW"-Eingangs ist, dass er nur sehr geringen Strom zieht, also direkt von einem GPIO-Pin (oder einem Arduino) angesteuert werden kann. Wenn man den Verstärker direkt über die Spannungsversorgung schaltet, kann das nicht nur ein hässliches Knackgeräusch verursachen, sondern wegen des möglichen hohen Einschaltstroms muss auf jeden Fall ein Relais oder kräftiger MOSFET dazwischen.


    LG


    pah

  • Ich glaube, Masse und + des Audio-Eingangs nicht vertauscht zu haben. So habe ich das Audiokabel angelötet:


    Das müsste doch richtig sein, oder?


    Aufgrund der Aussagen von pahenning und Nea bin ich nun etwas durcheinander. Ist es nun normal, dass der Verstärker bereits aktiv ist, wenn ich ihn nur mit 5V versorge, ohne dass ich GND anschließe? Oder ist das nicht normal?


    Gruß,
    Christoph

  • Muss jetzt auch nochmal nachfragen. Habe kein PiFace und wollte den Verstärker über die GPIO's an und ausschalten. Wäre es denn richtig wie ich den SW und GND im Bild (von HanSolo) angeschlossen habe und wie müsste ich das in der ini ansteuern? Oder geht das so garnicht? @pahenning Kondensator ist bei mir nicht dazwischen. Danke

  • Nein den Ground neben dem SW Pin benötigst Du nicht da du diesen über die GPIO Kontakte beziehst. Du musst dir die .ini soweit dann anpassen das wenn der Verstärker benötigt wird dann kein Signal also Ground auf dem SW Pin liegt und wenn Du den Verstärker deaktivieren möchtest muss das Signal anliegen.

  • So würde ich es jetzt bei mir einfügen. Nach dem Schema vom oberen Bild allerdings ohne GND

    Code
    1. [onboardpins_OutputPins]
    2. 16 = Verstaerker
    3. [EVENT_OnKeyPressed_onboardpins.29]
    4. #(Eingang Bewegungsmelder, weckt das Display auf)
    5. 10 = out:sleep=0,1
    6. 20 = out:Verstaerker,1,0,185

    Wäre das so richtig? Also würde er an gehen und nach 185 Sekunden aus oder genau anders herum?

  • Wieso schaltest Du denn den Verstärker durch den Bewegungsmelder, hat das einen besonderen Grund?


    Genau anders herum.


    Ich würde es so machen:

    Dein sleep Befehl ist bei dir falsch geschrieben.