Soundkarte funktioniert nicht

  • Hallo
    Ich komme einfach nicht weiter. Vielleicht habt ihr eine Idee.
    Das ganze läuft auf einem pi3,
    wenn ich denn Taster am piface drücke läutet das Telefon aber keine Sprachübertragung.
    Generel habe ich keine audioausgabe.
    Hier noch die ausgaben über putty:



    Code
    1. pi@DoorPi:~ $ cat /proc/asound/cards
    2. 1 [Device ]: USB-Audio - USB Audio Device
    3. GeneralPlus USB Audio Device at usb-3f980000.usb-1.4.1, full speed
    4. 2 [ALSA ]: bcm2835 - bcm2835 ALSA
    5. bcm2835 ALSA


    Code
    1. pi@DoorPi:~ $ lsusb
    2. Bus 001 Device 006: ID 2341:8037 Arduino SA
    3. Bus 001 Device 005: ID 1b3f:2008 Generalplus Technology Inc.
    4. Bus 001 Device 004: ID 0424:2422 Standard Microsystems Corp.
    5. Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
    6. Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
    7. Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

    pi@DoorPi:~ $ sudo nano ~/.asoundrc


    Code
    1. pcm.!default {
    2. type hw
    3. card 0
    4. }
    5. ctl.!default {
    6. type hw
    7. card 0
    8. }


    Gruß Markus

  • Danke für die Hilfe


    doorpi.pni

    dmesg | grep usb



    Edit: log Gelöscht

  • Hallo Markus,


    die LOG-Datei und Konfig sieht IMHO eigentlich ganz gut aus.


    Da fällt mir auch nicht mehr viel zu ein.


    Alle "Kanäle" der Soundkarte eingeschaltet?
    sudo alsamixer; Mit F6 Soundkarte auswählen + Enter; Mit F5 alle "Kanäle" anschauen.



    Für den Anfang muss überall "00" stehen (Auswahl mit Cursor-Tasten; Ändern mit "m") und den "Pegel" hoch drehen (Mit Rauf/Runter)


    Sonst die Hardware (Leitungen, Lautsprecher, Mikro) noch mal woanders testen. Am PC oder so.


    Viele Grüße
    Olaf

  • Hallo Markus,

    wen ich

    Code
    1. aplay /home/doorpi/sounds/bigben_mono.wav

    eingebe spielt der raspberry 3 über klinke ab

    Dann läuft die Soundkarte ja erst einmal. :thumbup:


    IMHO liegt es wohl zwischen DoorPi und Fritzbox. Von der Fritzbox habe ich nicht so den Plan.


    Rufnummer "**2" ist richtig? Muss da nicht die "11" (call:11) oder so angerufen werden?


    Viele Grüße
    Olaf

  • Frohes neues Jahr,


    Nein die bordeigene Soundkarte des Rasperi 3 spielt den sound ab ich bekomme ihn auch nicht auf die usb soundkarte ausgegeben.

    Ahh, OK. Schade.
    Dann mal horchen, ob bei speaker-test -c 2 -D hw:1 ein Rauschen zu hören ist.


    Wenn ich den taster drücke leutet das Telefon also kann es doch auch nicht an der fritzbox liegen, oder doch?

    Stimmt. Hatte ich verdrängt, dass "nur" kein Sound raus kommt aber das Telefon klingelt.



    Viele Grüße
    Olaf

  • Ich habe jetzt das rauschen auf den USB Lautsprecher aber der ton vom Telefon kommt nicht an.

    Dann läuft die USB-Soundkarte auch :thumbup:


    Ich habe jetzt die Primäre Soundkarte in alsa auf usb umgestelt.

    Dann sollte aplay auch "normal" über usb funktionieren.
    (Z.B. aplay /usr/local/lib/python2.7/dist-packages/linphone/unittests/sounds/ahbahouaismaisbon.wav
    Gibt schon bekloppte Sounds ...)



    Vielleicht liegt es dann an den Ports welche für RTP benötigt werden?


    Irgend etwas zwischen DoorPi und Fritzbox geschaltet? Firewall, Router, ...
    DoorPi hängt am Gastnetz der Fritzbox? (Ich weiß allerdings nicht, ob das eine Rolle spielt)
    Oder ein Doorpi in der Fritzbox nochmal einrichten ...


    Viele Grüße
    Olaf